Troubles with running a test [jME version 2]

I have downloaded  the jME(2) and now it's installed in my pc…

I have Eclipse, and I read the "Eclipse Guide to jME"


but when I trying to run one of the tests in the src folder, it's saying that:

java.lang.UnsatisfiedLinkError: no lwjgl in java.library.path
   at java.lang.ClassLoader.loadLibrary(
   at java.lang.Runtime.loadLibrary0(
   at java.lang.System.loadLibrary(
   at org.lwjgl.Sys$
   at Method)
   at org.lwjgl.Sys.doLoadLibrary(
   at org.lwjgl.Sys.loadLibrary(
   at org.lwjgl.Sys.<clinit>(
   at org.lwjgl.opengl.Display.<clinit>(
   at com.jme.system.lwjgl.LWJGLPropertiesDialog$
   at jmetest.renderer.TestTeapot.main(

can you help me please?  :wink:

(sorry for the bad english)

follow the tutorial more closely :slight_smile:

look for 'Native Library Location ' in the tutorial

amm… I follow the tutorial very closely and I still didn't found the problem…


In your post, you referenced to the jme1 set up guide, but its mostly the same.

  1. Right-click on jme → Properties. Navigate to Java Build Path and choose the Libraries tab.

  2. Finally, we need to tell LWJGL where to find its native implementations. In the

thanks, I'll see if it works.


I can't find this "Preferences (Filtered)” window.

can you take a screen shot and show me? :confused:


ok it works! thanks!

anyway, I have another question- what is this warning means?:


26/03/2009 00:18:06 com.jme.system.PropertiesIO load

WARNING: Could not load properties. Creating a new one.


The warning is ignorable.

I believe its from saving the display settings in the dialog box that appears when running any of the samples (where you choose screen resolution etc).


Thank you  :slight_smile: