Tutorials out of date?

Hey. I just signed up to the forum as I've just decided to start using JME for a little side-project to keep myself busy. I'm currently in University studying Computer Science, which focused on coding in Java for the first year but eased off on the coding this year - as a result, I got a little bored and I've decided to take up a project of my own. I'm going to make a crappy little game that I can play with friends over the internet. I've got experience with coding programs to use basic sockets and I decided to try my hand at some of the 3D engines out there. At first, I tried Java3D but, much to my frustration, the community wasn't set up around it to help people, often ending in people poking fun when I had a problem or telling me to give up coding in Java altogether when I asked a basic question that FAQs and docs didn't handle. I switched to Xith3D and worked through some tutorials to get to grips with the basics and made a simple program where you could log into a server over the internet and rotate a cube (ok, maybe not too impressive but the basics are there ^^). Anyway, as soon as I found out about Java Monkey Engine, I started reading around and asking the advice of some programmer friends. Originally I was put off by the fact it used Open-GL as opposed to DirectX but then I realised that Open-GL's platform independancy lends itself to Java programming while DirectX, if I'm not mistaken, is pretty much restricted to Windows machines.

First off, I have to say that the website is spectacular and the demos (although they did have a tendancy to quit out after 10-60 seconds) were superb at demonstrating some of the built-in abilities of the engine. I don't pretend to be an amazing programmer nor do I pretend to have any experience with Open-GL. My mathematical skills are not the best, either, but I have a habit of picking things up pretty quickly when they have a practical use (never did too well with pure maths but applied maths is better). Having an engine like this with a nice community built up around it is probably the best thing I could ever have hoped to find.

Anyway, what I was going to ask is if the tutorials are out of date here: http://www.jmonkeyengine.com/wiki/doku.php?id=learning_jme

They make references to classes that have different paths in the package than in the code and some of the constructors for certain objects don't appear to be happy. I'm wondering if there are some new tutorials or a timeframe on these ones being updated to the current version. The first few that worked introduced some pretty nice basic concepts and reading through the rest, it would probably help more if I had working programs to refer to. That said, I can probably get by with the docs and bugging people on the forums ^^.

Basically, yes, those are out of date. However, they were move to the wiki so that they could be updated easily (they were originally in PDF format and didn't lend themselves to easy updating). Basically, they need to be fixed here and there. Although most (if not all) of the material is current, the syntax has changed here and there. If you find specific problems, post in the documentation group in this forum and they will be fixed fairly quickly.

Having said that, the most curious statement from your post for me is that the demos have a tendancy to quit after 10-60 seconds. That's a bit worrisome. Can you give more specifics so we might figure out what this is about?

And welcome. :slight_smile:

I don't know why, but they jsut vanish. I open them using Java Web Start as I would normally and I move about, look at the object from a few angels and then all of the sudden it vanishes.

Next time you get a chance, can you run the webstart demos with the Webstart console on? Perhaps an error is displaying.

Sure thing. How do I enable the console in windows?

Start Webstart itself (javaws.exe). There is a properties menu that will allow you to turn console on.

Thanks, I figured that out but yuo posted too quickly for me to edit my post ^^.

The web start console also quits out when the demo quits out. I logged everything to a file and the output was normal:

Java Web Start 1.4.2_06 Console, started Sat Nov 12 06:58:06 GMT 2005

Java 2 Runtime Environment: Version 1.4.2_06 by Sun Microsystems Inc.

Logging to file: <removed :)>

Nov 12, 2005 6:58:08 AM com.jme.app.BaseGame start

INFO: Application started.

Nov 12, 2005 6:58:08 AM com.jme.system.PropertiesIO <init>

INFO: PropertiesIO created

Nov 12, 2005 6:58:08 AM com.jme.system.PropertiesIO load

INFO: Read properties

Nov 12, 2005 6:58:11 AM com.jme.system.lwjgl.LWJGLDisplaySystem <init>

INFO: LWJGL Display System created.

Nov 12, 2005 6:58:11 AM com.jme.system.PropertiesIO save

INFO: Saved properties

Nov 12, 2005 6:58:11 AM com.jme.system.lwjgl.LWJGLDisplaySystem <init>

INFO: LWJGL Display System created.

Nov 12, 2005 6:58:12 AM com.jme.renderer.lwjgl.LWJGLRenderer <init>

INFO: LWJGLRenderer created. W:  640H: 480

Nov 12, 2005 6:58:12 AM com.jme.renderer.AbstractCamera <init>

INFO: Camera created.

Nov 12, 2005 6:58:12 AM com.jme.util.lwjgl.LWJGLTimer <init>

INFO: Timer resolution: 1000 ticks per second

Nov 12, 2005 6:58:12 AM com.jme.scene.Node <init>

INFO: Node created.

Nov 12, 2005 6:58:12 AM com.jme.scene.Node <init>

INFO: Node created.

Nov 12, 2005 6:58:12 AM com.jme.scene.Node attachChild

INFO: Child (FPS label) attached to this node (FPS node)

Nov 12, 2005 6:58:14 AM com.jme.scene.Node attachChild

INFO: Child (wall) attached to this node (rootNode)

The console had displayed all that already before it quit out.

I think 1.4.2_06 had a bug related to JNI that prevents it from working with many Java programs that use native libraries (like LWJGL). Try upgrading to  1.4.2_10 or 1.5

This is the second problem I've seen on the forums related to 1.4.2_06.  The bothersome part is that it was known as of the first post that this was a problem.  Wouldn't it make sense to put some code in that would check the JRE version at startup and if they're running a version that has known issues with jME that it could just pop-up a dialog and let them know instead of being stuck posting to the forums because it's nearly impossible to figure out that it's your JRE and not hardware or a bug?

Who knows how many people have given up jME just because of frustration and inability to debug this problem that never make it to the forum.

Just my opinion, take it at what it's worth. :wink:


Let's confirm this fixes the problem first, if it does -to begin with- I'll put it in the FAQ

Just a word regarding the tutorials: As Mojomonkey said, this was put from PDF to Wiki and refers to a previous jME revision.

As there were several small changes lately it does no longer fit to the CVS version.

I think this tutorial should fit to the latest stable version as it might be easier than to keep it up-to-date with CVS which is work in progress. Maybe we should state the jME version that fits in the tutorials. That way the reader can check it against the jME he's using and easily find out whether it's supposed to work or not.

What do you think?

PS: I'm referring to the "Learning jME" tutorial as mentioned above, the flag rush is part of the CVS version and runs fine.

I'm downloading the latest official release of the JDK and JRE, which is 1.5.0_05. I'll let people know how it goes.

Well, that fixed the problem. Thanks guys. I guess that JRE version does have problems with JME.

Entry added to the FAQ:


However, I notice we don't have a link to the FAQ yet in the bug posting guidelines.  :expressionless: