Twilight zone/Matrix/Black Hole area

This shows a video of an underground area with lots of something evil which I don’t know what it is.

Hopefully it can be fixed!

Looks like the video link was messed up.

Edit: never mind. :slight_smile:

Yes the server switch somehow messed up the youtube plugin, or maybe I don’t know how to embed it properly :open_mouth:

EDIT: Maybe its the bloom filter … Just guessing.

Btw, my specs:

Windows 7 Home Premium 64 bit

ATI Radeon 5770, Catalyst 10.11

4 GB Ram

Quad core 2.5 Ghz

Java 1.6u23

Ah, you found the disco levels… :wink:

Seriously, though, there’s something definitely wrong with the shaders on your box… for one, there wasn’t any water in that little sandy pond on your way there.

In the case of the disco lights, I suspect this is what happens on your hardware when my shaders are coping with 0 light. You should be able to get the same effect just by digging a tunnel in the side of a cliff face. About 8 or 9 meters in or something it should be completely black.

A hint for those who care, the heads up display shows the current light levels for the cell you are standing in (not the one at your head but the one at your feet) That’s the 0/15 @ 0 stuff you see. The first number is ‘local lighting’, ie: ‘fire light’, the second number is sunlight, 15 is the max. The third number is the cell block type which I think is always 0 in walk mode.

When you see the disco effect, you can try dropping a ‘fire light’ (number 29 in the block types) to see if it goes away.

P.S.: Even though it was to show a bug, there’s something really cool about seeing someone else’s walkthrough video of your game. :slight_smile:

If it’s the bloom filter, you can toggle that off/on with F1 to see.

…given what you had to go through to get it there, I suspect 0/0 light… and that somehow that is blowing out my shaders.

Edit: P.S.: Thanks for posting the issue.

I had the same issue when going deep underground. I can’t see how it could be the bloom filter though, the issue is located on the boxes.

specs are :

win 7 64 bit

6 gb ram

quad core 3.2ghz

Ati Radeon 5970 2gb x2 cross fired

But really have to go very deep underground…not a major issue IMO

So, assuming it’s a shader bug, there is no difference at different levels if sunlight is getting in. You can dig as deep as you want and level 15 sunlight will still follow you straight down.

If you dig to the side, however, the light really starts to fall off fast, especially with just one opening to sunlight. But ultimately it’s no different than digging a long cave in the side of a cliff. Or just digging a very shallow cave and blocking off the entrance which puts you in pitch black instantly.

I’d be curious to see if any of those other approaches replicates the issue if anyone ever gets to test again. It would significantly narrow down what the problem is and gives me a “hack” of a way out if I can’t figure it out (since I could always never let light hit 0 if that’s really what it is).

I have not been able to replicate this issue, testing on Ubuntu 10.10 64-bit, GeForce 8600M GT. I tried straight down and then to the side as well as downwards in a slope, never encountered that odd visual. I only get pitch black blocks.

I did however encounter a different twilight zone of my own:

The second picture indicates where I was standing when I saw that weird stuff. It happens when you’re underneath the edge of a block. Jumping into it you can get glimpses of it, but somehow when digging my way down I got stuck in there. During this little session I also got myself stuck in a repeated jump, until I pressed the jump button again. I should record my test sessions from now on…

You fell through the ‘surface’ of the world and, while you were still in solid rock, I don’t draw the blocks that are fully enclosed so you can see the underbelly of the world. A neat effect but ultimately not desirable. :slight_smile:

This will be better in tomorrow’s release but unless I get a little time to tweak it some more, it will still happen. Sometimes when I’m jumping or falling and some new terrain chunks in, it’s enough to turn small physics impulses into overly large ones if the physics thread misses a few frames. At least now it doesn’t do that weird vibrating oscillation.

…I’ll probably put a heavy handed fix in for tomorrow just to try and eliminate the problem.

erlend_sh said:
I have not been able to replicate this issue, testing on Ubuntu 10.10 64-bit, GeForce 8600M GT. I tried straight down and then to the side as well as downwards in a slope, never encountered that odd visual. I only get pitch black blocks.

I did notice that both cards (so far) with the issue have been similar models of ATI. Perhaps those cards are exploiting some bug in my shader code or vice-versa.

I might have figured this one out. When there is no sun and no local light, I don’t initialize all of gl_FragColor. This will be fixed in the next version… and hopefully fix the issue.

…assuming my previous assumptions about the conditions under which it occurs are correct.

So the new test build is up. I would be ever so appreciative if you guys with the twilight zone problem can confirm or deny that I fixed it. :slight_smile:

1 Like