Ubuntu11.04 + JME 3 Alpha + ATI RADEON HD 4500 Series. Problem with OpenGL 2.0

I’ve a problem when i’m executing JMonkeyEngine. The program crash and it show me this error message. Any ideas?

Error opening OpenGL windows!

Your graphics card needs to support at least OpenGL 2.0,

if that is the case, please download the latest drivers.

Error: Failed to create display

Error: Failed to parent canvas to display

Running on jMonkey Engine 3 Alpha 0.6

Extraction Directory #1: file:/home/osb/jmonkeyplatform/jmonkeyplatform/modules/ext/

Extraction Directory #2: /home/osb/.jmonkeyplatform

Extraction Directory #3: /home/osb

DesktopAssetManager created.

EDT: Creating OGL thread.

Using LWJGL 2.7.1

Display created.

Adapter: null

Driver Version: null

Thanks :slight_smile:

What’s your graphic card and its driver?

looks like you need to update your video card drivers.

Ubuntu11.04 + JME 3 Alpha + ATI RADEON HD 4500 Series

Hmm, I didn’t see that. Yeah, update the driver.

Edit: The open source Mesa driver works fine in my ubuntu 11.04.

I’ve tried with 2 or 3 kinds of drivers, and it doesn’t work yet. I’ve ATI RADEON HD 4500 Series :slight_smile:

Does unity 3d or blender or some hell 3d work fine in your system? Did you try to install the driver provided by “system---->additional drivers”? It worked for me. Right now I’m using a desktop pc with an ati driver (I think it’s a 4500 series too), and jmp works fine here. Take a look:

Well… I’ve installed this driver and now it seems that works. But…


The program closed automatically when it reach to this part(?).

Ok, As you are having problems with the Welcome Screen, i have a possible solution for you:

-go to command line

-edit the welcome.properties and disable the welcome screen :

sudo nano ~/jmonkeyplatform/dev/config/Preferences/com/jme3/gde/welcome.properties


sudo gedit ~/jmonkeyplatform/dev/config/Preferences/com/jme3/gde/welcome.properties

good luck.

Why? U not in the jMonkeyPlatform group? :slight_smile:

1 Like

Just update to nightly. From what you posted the application does not “crash” but simply doesn’t open the OpenGL window.

:/, I can’t fix the ugly command lines I’ve wrote above -.-.

yay. normen is a wizard :D.

I’ll try tomorrow to solve this problem. Thanks for every ideas :slight_smile: