Unable to find JVM on exported project

I have built a project.

So, I open PlaneStorm-windows, and click on the executable.

But I then get these:

I tried bundling the JRE in, but this didn’t work either as it resulted in an unsuccessful build.

What is causing this? Could my potential users get this issue? And, how can I solve it?

Thank you

Bumping the thread. I need this solved in time for an alpha test with fellow developers, and need to get it exported ASAP.

So first:
If they run into that error they should just install the Java JRE and (if it still occurs, check if their JAVA_HOME is properly set).

I don’t know much about launch4j or what we are currently using for deployment, but:
If you mean you clicked the button “Bundle JRE with Applications” in the SDK, it would be helpful to state WHY the Build actually failed as that’s what pops up the Message Boxes in the first place

Edit: After looking into it the JRE Download seems to fail atm
Edit2: I found the root of it: The SDK tries to download whatever JRE itself is being run off. This leads to problems when you use 3.0 or the 3.1-alpha1 or w/e, since it’s jre isn’t available anywhere.

As a workaround, you can download the latest jre from oracle.com and place them into BasicGame/resources/desktop-deployment/jre-windows-x64.tar.gz (don’t forget the x86 as well)

Could you link me to the JRE? I can only find the installer at the moment, and not the actual file required.

Click Accept and select the matching .tar.gz files.

Thank you very much. Unfortunately, the resources now don’t seem to be in the built ZIP files. How can I solve that?

I don’t get what you mean?
The best thing is simple removing the resources/desktop-deployment folder and then in the Project Properties unticking and ticking “Download Bundled JREs” and pressing Okay.

That will try to download the JREs where it will fail again. The key point here is that it rebuilds the windows-x64 folders and such.

Then you just swap out the .tar.gz files and press Clean & Build again.
Note: The Zip Thing complaining about a closed/broken stream or something mostly means your .tar.gz file is incomplete (e.g. an uncomplete download).

No matter what I need a clear Error Message to actually know what’s going on.