Unable to run jMe 3 SDK

Hi,

I m running Windows vista in my laptop with following display configurations,



OS = Windows Vista Home Basic

Device{Mobile Intel 945 Express Chipset :: 256MB :: Internal }

Driver {igdumd32.ddl v 7.14 :: DDI Version = 9Ex }



I couldn’t run jMe 3 SDK in my machine, it gets stuck in 14% when it is loading the scene graph view.

(I tried even in Ubuntu 10.10 also, still same situation in my machine)



========================================================



Same version of jMe 3 SDK I tried to run in the machine with flowing configurations,



OS = Windows 7 Ultimate

Device{Mobile Intel 965 Express Chipset :: 358MB :: Internal }

Driver {igdumdx32.ddl, igd10umd32.ddl v 8.15 :: DDI Version = 10 }



and jMe 3 SDK is running here without any problem.



Please advise on me what should I do to make this running if it is possible.

It will be really helpful to me as these days I am doing my literature survey for my research proposal. If I could go with JMonkey smoothly I am relay confident on choosing this as my 3D engine.



Thanks,



Dilunika.

Your card has to support OpenGL2, update the drivers if it does.

Thanks Norman for your immediate response.



According to following source Intel 945 Express Chipset supports OpenGL 1.4 - Intel GMA.



When I check, my drivers also up to date. Is there anyway to configure my Graphic card to support OpenGL 2.0 with software level upgrade?



Otherwise, is there any way to use jME SDK, atleast an older version, with my machine configurations?

No, its a hardware requirement. We are working on bringing basic OpenGL1 support to jME3 but its really designed for OpenGL2 and above.