Unknown error running a file in IDE

Having some issues running a file in the IDE. When I run the file I get this as output:

Java Result: -1073740791
BUILD SUCCESSFUL (total time: 1 second)

Nothing pops up allowing me to see what I have just designed. No idea how to fix this issue. Any help would be great.

Thanks in advance.

What version of the IDE do you use?
What file do you want to run? Can you post the source code?
Without that, we can’t help you.

So basically I am following the tutorials to get used of the engine before I try and do anything more complicated with it. I have tried everything to no end. I use the latest version of the IDE. SDK version 3.0. Here is the code.

   package jme3test.helloworld;

import com.jme3.app.SimpleApplication;
import com.jme3.font.BitmapText;
import com.jme3.light.DirectionalLight;
import com.jme3.material.Material;
import com.jme3.math.Vector3f;
import com.jme3.scene.Geometry;
import com.jme3.scene.Spatial;
import com.jme3.scene.shape.Box;

    public class HelloAssets extends SimpleApplication {

        public static void main(String[] args) {
            HelloAssets app = new HelloAssets();

        public void simpleInitApp() {

            Spatial teapot = assetManager.loadModel("Models/Teapot/Teapot.obj");
            Material mat_default = new Material(
                assetManager, "Common/MatDefs/Misc/ShowNormals.j3md");

            // Create a wall with a simple texture from test_data
            Box box = new Box(2.5f,2.5f,1.0f);
            Spatial wall = new Geometry("Box", box );
            Material mat_brick = new Material(
                assetManager, "Common/MatDefs/Misc/Unshaded.j3md");

            // Display a line of text with a default font
            guiFont = assetManager.loadFont("Interface/Fonts/Default.fnt");
            BitmapText helloText = new BitmapText(guiFont, false);
            helloText.setText("Hello World");
            helloText.setLocalTranslation(300, helloText.getLineHeight(), 0);

            // Load a model from test_data (OgreXML + material + texture)
            Spatial ninja = assetManager.loadModel("Models/Ninja/Ninja.mesh.xml");
            ninja.scale(0.05f, 0.05f, 0.05f);
            ninja.rotate(0.0f, -3.0f, 0.0f);
            ninja.setLocalTranslation(0.0f, -5.0f, -2.0f);
            // You must add a light to make the model visible
            DirectionalLight sun = new DirectionalLight();
            sun.setDirection(new Vector3f(-0.1f, -0.7f, -1.0f));


The output I posted in the original post is what I keep getting.

The latest Version is actually 3.1-beta2 (even 3.1-beta3 actually but the automated build is flawed).

Apart from that, do you have the latest Nvidia Driver? If so you can fix it like this:

Yes I have the latest drivers for all my hardware. I try to keep everything in my system updated. Ill try updating to that build then. Ill let you know if it works.

Just to clarify that, you have to downgrade your driver, not update. They somehow destroyed OpenGL, it also happened to a lot of Life In the woods (Minecraft) Players as well

1 Like

It worked. The driver was the issue. Thank you for your help !! Much appreciated.