UnsatisfiedLinkError out of nowhere?

So, yesterday I was working on my game just fine. Today, out of nowhere, when running the project, it gives me this error:

Exception in thread "main" java.lang.UnsatisfiedLinkError: C:\Users\Ricardo\Desktop\Projetos JME\Strategy Client\bulletjme.dll: Can't load IA 32-bit .dll on a AMD 64-bit platform
	at java.lang.ClassLoader$NativeLibrary.load(Native Method)
	at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1937)
	at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1822)
	at java.lang.Runtime.load0(Runtime.java:809)
	at java.lang.System.load(System.java:1086)
	at com.jme3.system.NativeLibraryLoader.loadNativeLibrary(NativeLibraryLoader.java:683)
	at com.jme3.system.JmeDesktopSystem.initialize(JmeDesktopSystem.java:348)
	at com.jme3.system.JmeDesktopSystem.newContext(JmeDesktopSystem.java:271)
	at com.jme3.system.JmeSystem.newContext(JmeSystem.java:162)
	at com.jme3.app.LegacyApplication.start(LegacyApplication.java:461)
	at com.jme3.app.LegacyApplication.start(LegacyApplication.java:424)
	at com.jme3.app.SimpleApplication.start(SimpleApplication.java:125)
	at main.Main.main(Main.java:20)

Lokks like there’s something wrong with the bulletjme.dll file. However I copied the file from my github repo and from another working project, and it’s still giving me the same problem.

The thing is, if I run the project using the JME SDK instaled on my USB drive, it works fine. What the hell happenned during night? Did any of you had a similar issue?


Delete or rename the file and relaunch the Application, it will Auto extract the right version

1 Like

Thanks, that worked.

On another note, I really want to use another SDK, since jME’s SDK is so buggy for me. But the thing is I really need the SceneComposer, TerrainEditor and the other tools to work in my game. Is there a way to implement those tools on another IDE?

You could do like many of us and just use the SDK as a scene editor, terrain editor, etc. and edit our code itself in something else.

After all, photoshop, blender, etc. doesn’t run in an IDE and no one seems to complain about that.