Update = crash

So i updated SDK, then after it i had error that not all modules can be loaded.

i tried turn on modules and turn off but nothin worked.

So i just removed JmonkeyPlatform and downloaded/installed a new one.

Still same error. I cant open aby projects/etc.

When i try open project i have in name “<unrecognized project; missing plug-in?>”

i will try to fix it now, but help is greatful

Make sure you delete the app and settings (best using the uninstaller) and reinstall.

  1. Removed with option to remove app data(yea before i dont used this option)
  2. Removed all jmonkeyPlatform folders
  3. installed via jME3_SDK_Alpha-4-windows.exe(just downloaded)
  4. Run Jm SDK aaaand work!

    Tnx for advice

    Now i must just again configure it :slight_smile:

some update after reinstall and:

Warning - could not install some modules: jME3 Code Checks - The module Java Hints was requested in implementation version “4” but only “5” was found.

it shouldnt be on fresh installed version :slight_smile:

code checks:

Version: Source: jMonkeyPlatform Alpha-4
Plugin Description
Gives code hints and performs checks on code during compile

IIRC uninstalling the plugin then redownloading should fix that problem.

Yeah, you might have to disable code checks after the first update, you can re-enable it after that. However for the nightly update center I don’t have that problem anymore.

Strange, when i uninstall it, it is still in “installed” as not activated

aaaand, i cant uninstall it again…

there is only option to activate but it dont work…

oxplay2 said:
Strange, when i uninstall it, it is still in "installed" as not activated

aaaand, i cant uninstall it again............

there is only option to activate that dont work...

You have to restart jMP after disabling it.

i restarted before…

It do nothin.

edit: dont know if it will help but i have RCP platform plugin as activated but it is “grey” and i can do nothin with it


As I was checking my plugins I noticed that Code Check is also disable here… Uninstalling didn’t do squat. It’s still there, greyed-out. You can’t uninstall it anymore. The only option is to “Enable” it, which of course doesn’t work…

I just also noticed that the new GDE asks for Java SE project and won’t update because of that… O_o

I guess a reinstall from scratch will soon be needed for me too then. :expressionless:

Got rid of CodeCheck. Trying to get it again tells me Java Hints v5 is needed…

The GDE->Java SE says it needs v45.

I’ll reinstall later from Nigthly and see how it goes.

Its not so important, just leave it off, beta is coming soon anyway :wink:

Sounds good to me. :smiley:

I wasn’t in a hurry to update either since everything is working right. :slight_smile:

yea its nice, i was afraid i will never update it “more” :smiley: