Updated Nifty, Fonts now crazy…

Hey guys, I’m so confused. I just updated Nifty within the Windows JME SDK (I needed the nifty.setIgnoreKeyboardEvents() function).

Well… i’m not really sure why but this…

has become this…

It was working perfectly fine before hand.

Edit: just some more info. I tried resetting the font within the nifty xml file (created a basic arial.fnt file and referenced it) but it still shows the same crazy layout as above.

I am seeing the same thing.

What do you mean “you updated it”? As in you grabbed some nifty nightly and linked it in your project?

I grabbed the update from within the SDK. It showed up in my plugin updates. I downloaded, installed, restarted the SDK and when I ran my project this is what happened.

Same issue by updating from the SDK today.

So our nightly, with the “Breaks!” remark? :wink: Okay, hope you guys have enabled nightly in a test app as outlined in the manual cause idk how long it will take until nifty is fully working in nightly and you cannot revert.

dam, I just updated now to see, out of curiosity and yes its screwed ^^ (I updated yesterday and it worked fine then, so it was caused by changes yesterday)

Feels good that it’s a shared problem and not something I have to rewrite my interface for. :roll:

@alanspike said:
Feels good that it's a shared problem and not something I have to rewrite my interface for. :roll:

You should never assume anything like that when you are using nightly.

This seems like the most likely cause:


For me nifty in nigthly caused my game to “freeze”, it drew half of a panel background (has alpha 0.5 if that might matter) then nothing happens. I can see in the debugger that lwjgl and others (like terrain) threads are running but nothing gets updated - screen is black with a halfway drawn panel. So yeah, the promise in nightly of Breaks! is not a lie :smiley:

The good thing with nightly is that I can help find bugs and even might help fix things, that’s sort of what you sign up for when using nightly.

1 Like

The issue has been fixed in SVN


yep works :slight_smile: thanks