Urgent Bug : SecurityException in Version 0.7

There are diferent signed classses (most LWJGL…) in jme.jar, so that a program can’t run correct.

(User must create a new jme.jar. The new jar shrinks to the half size)

Compiling sources from cvs is also not possible, there are classes with

errors (not ready or so…).



A call getVersion() shows Version 0.6, not 0.7.Is this ok?

C:Documents and SettingsMeIdeaProjectsjme>ant
Buildfile: build.xml

init:

compile:
[javac] Compiling 361 source files to C:Documents and SettingsMeIdeaPro
jectsjmebuild

BUILD SUCCESSFUL
Total time: 16 seconds
C:Documents and SettingsMeIdeaProjectsjme>


Builds work for me. Can you describe the error you're getting trying to compile the code.

The error occurs only if i call ‘ant dist’.Call ‘ant’ alone it works.

C:Documents and SettingsMeIdeaProjectsjme>ant -f buildtest.xml dist
Buildfile: buildtest.xml

init:

compile:
[javac] Compiling 129 source files to C:Documents and SettingsMeIdeaPro
jectsjmetestbuild

dist:
[jar] Building jar: C:Documents and SettingsMeIdeaProjectsjmetarget
jmetest.jar
[jar] Building jar: C:Documents and SettingsMeIdeaProjectsjmetarget
jmetest-data.jar

BUILD SUCCESSFUL
Total time: 12 seconds
C:Documents and SettingsMeIdeaProjectsjme>ant -f build.xml dist
Buildfile: build.xml

init:

compile:
[javac] Compiling 361 source files to C:Documents and SettingsMeIdeaPro
jectsjmebuild

dist:
[jar] Building jar: C:Documents and SettingsMeIdeaProjectsMetarget
jme.jar

BUILD SUCCESSFUL
Total time: 15 seconds


What kind of error are you getting?

Ok you are right. I have other ant build files where the call ‘ant dist’ has another job to do.