Using 3DS Max Animations in jME

I’m using 3DS Max 2013 and the jME3 beta. I have converted my models to ogre files using the XML Exporter and placed them in the respective jME source file location for models. To be frank I don’t think some of my models are working as 3DS Max crashes when I render the scene and when I add them to the top node in jME it gives me an error and never adds them. But that’s a problem I’m working to solve in 3DS Max. For now I have a fairly large quantity of working animations that I have made in 3DS Max and I want to figure out how to import them so that when I do get my models working I know how to do so. This problem is not urgent but if someone would be willing to point me in the right direction I would be very grateful. I can probably figure out how to do this once I know how to import the animations, but the end goal is to have several animations (such as a candle flame) running on a loop and others (Such as a spike trap) running on a timed cycle.

Thank you for your time.

I’ve only used the Blender Ogre exporter, but with that when you export a model with animations you get a skeleton.xml file along with your mesh.xml file. In the SDK you right-click on the mesh.xml file and convert it to j3o, that will in turn convert your animations (they are displayed as an AnimControl in the SceneComposer, where you can then select an animation from the properties window on the right.

Make sure to turn on the light in the scene composer to see the model.

Hey, I tried exporting my finished 3DS Max scene that renders okay now in 3DS Max, but when I import it into jME and add it to the scene composer all I see is black space with some red boxes in each place of where a model should be in the scene. I have quite a few lights in my real scene and adding an extra light in jME doesn’t change anything either. I’m not sure what to do, maybe my scene exported incorrectly or something is wrong with importing it into jME. All of my lights in 3DS Max were photometric lights so I’m not sure if those export properly or not. If you have a chance, some help would be greatly appreciated, thanks.

Do you have a screenshot of what it looks like when loaded in the scene composer? The lights might not have imported; you can always turn on a temporary light in the scene composer on the top left of the window (the light bulb).

Yea the temporary light does not change the scene.

Here’s a screenshot:

Can you pose some of your mesh.xml file? (not the whole thing if it is gigantic, or maybe post a link to download it)

You can sort of tell in there what geometries were exported and if they have a similar triangle count etc.

Here’s a link to a rar containing my ogre exported scene and my original max scene for reference.

Do lights imported into jME only show up as dummies, forcing you to use the much weaker and less comprehensive built-in jME lights?

@keyert said:
Here's a link to a rar containing my ogre exported scene and my original max scene for reference.

These are ogre binary files, do you have any exported mesh.xml ogre files?

@keyert said:
Do lights imported into jME only show up as dummies, forcing you to use the much weaker and less comprehensive built-in jME lights?

Lights are basically math used for the shaders. If the lighting shaders in jme do not implement all the features of 3ds max then you will not see the same effects. When moving things into a game world, they often have to change no matter what engine you use. Same goes for materials: an editor probably does things differently than a game engine.
There are dummy markers in jme for lights in the scene composer, at least with point lights. They look like a light bulb, not a red box.

Well these are exported mesh files and an exported scene what do you mean do I have mesh.xml files? The only option for Ogre to export a scene as is .mesh .scene or .model.

I haven’t used the ogre exporter for Max, so I am just guessing, but there should be an xml option when you export. This thread mentions the export options.

Thanks very much for that thread link, very helpful. I just exported these as .xml’s now, and here’s a link to download them:

Quick question: I have the .scene file along with its .material file, but when it exported it also gave me a .mesh.xml for every single one of the separate models in my scene. Where should I put these for jME to recognize them? Before I just placed the .scene file with its .material file by themselves in the jme assets/scenes folder, because that’s what was shown in the importing scenes tutorial. Maybe I’m just getting these rectangular boxes because it can’t load the individual models of my scene. Where would you suggest I place each of the individual .mesh.xml files?

Thank you very much for your help kind sir.

Edit: Placing the model files with my scene file worked! I can see my scene now, but unfortunately none of the materials that had substance maps or bitmaps on them loaded. Also the lighting is extremely bright, despite it being very dark in my 3DS Max scene. If I click on the light in the scene editor there are hardly any options for adjusting it. Is there a better way to solve the problem?


Regarding the bright lights: I see a lot of lights with over 1.8 color diffuse value. Sometimes it may require using HDR to display properly. You can also reduce the intensity of the lights in 3dsmax.

Regarding missing textures: I see some references in the material files, e.g. “Propaganda.jpg”, “Poster.jpg”, “Urban-Worker-Posters.jpg”, but these images are missing from the RAR.

Thank you for your reply. I will place these images in jME’s textures folder. In regards to the lights, in 3DS Max the scene is very dark already, it’s just when they are exported into jME that the lights become very bright. When I click the lights under the scene editor, it gives me a mesh file and normal mesh properties. How do I change a light’s color diffuse values or enable HDR to see if this fixes the lighting problem?

Edit: I placed the images in both the textures folder of jME and right next to my models in my scene folder. Neither allowed jME to load the images.

Placing the images in the same folder as the scene should work. As for the lights, it would look incorrect in Ogre3D as well so I’ll have to blame the 3dsmax exporter for this one. You can always make it darker by processing the scene after it has been loaded into jME3