UV Coordinates messed up when applying j3m


I’m importing a model into the jMP. At first everything seems ok! The model gets imported correctly and is previewed correctly in the SceneComposer.

Then i create a j3m for adding my normal map. My j3m looks like this.

When i preview my model now, it looks like this

Does anyone have an idea what’s happening?

You have to generate tangents on the model to use normal maps.

Wow, you’re quick :slight_smile:

Ok. I can generate tangents on the models in the Exporter.

Is there any way to see if this worked out / the tangents are correct?

Heh, the model should be correctly lit ^^

Also don’t forget to set shininess on the material to a non zero value … We really should fix this bug lol :slight_smile:

Ok, after setting

  • the shininess to non zero
  • generating the tangents
  • setting the normal map (and diffuse map) to “repeat” (this fixed the “striping” texture on front of the building in the 3rd image)

    I got the model to work more or less in the right direction. It’s suffering from the “look i’m plastic look” right now, but that’s an entire different subject to look into.

    Thanks for your tips and help. Hope this information helps someone else out as well.

To get rid of the plastic look set “UseMaterialColors” to true and then set “Specular” to ColorRGBA.Blac

1 Like