Uv Mapping on import problem

Well I have this weird problem with this model here (note that many other models mostly work, only some few have this problem I have no Idea what could cause the uv mapping act like this.)

Attached is the exported mesh.xml as well as the source .max file, and needed materials.Any ideas what could cause this behavior? Thx.





http://nh-game.net/export/space_station.7z



http://nh-game.net/export/shouldbe.png



This is how it looks:



http://nh-game.net/export/howitis.png

Image flipped?

Hm thats it you are right. What causes this to only happen on some models? For the rest I dont have to flip the texture.

I don’t know, modeling software is funny with different formats… Thats why we gave up supporting more than two formats :wink:

Edit: Maybe you scaled it to a negative value and flipped the normals somehow?

Well for anyone using 3dsmax this here works:


  1. Flip image with whatever image tool you prefer horizontaly

    → Now the export should look correct, however in 3dsmax the image now is inverted.
  2. Openup material Editor

    http://i.imgur.com/bfeeR.png

    Click rotate, drag from down x to up x 180degree, it should sna at 180degree (not the cursor, but you will see this in the preview)
  3. Done, now the model looks correctly in 3dmax and in jme3.

In jMP, open the model, select the geometry in question, then select “create j3m file” in the properties window under “material” and save the file. Then open the j3m file and click the “flip” checkbox next to the texture. :stuck_out_tongue: