Version of renderer

Does JME support versions above of OpenGl 2.0?

As said, you can implement anything that can be done with shaders in jME3, be prepared however that stuff will not work across all cards and platforms, especially stuff like geometry shaders etc. while the jME3 provided shaders work. You have the graphics caps in the renderer for one, yes and you can specify GLSL version levels for different implementations of your shaders, look at the existing Lighting shader sources for examples on this.

Yes

and what version to be more precise?

It depends on what you do in your shaders :slight_smile: The built-in shaders use functions up to OpenGL 3.2 if available, no need to “enable” OpenGL3 or 4 or whatever specifically.

Also jme is build quite nice extendable, so you can easily create support for like geometry shaders or other opengl4.0 features that are not yet supported due to missing api.

So JME does not support tessellation or geometry shader…

How can be implemented this feature in the engine?

And how is selected the GL version? For example on the startup it’s done a caps scansion and selected the last version supported by GPU and drivers?