Virtual tour to Centre de la Imatge i la Tecnologia Multim

This is a Final Project of the University. Its located in Barcelona. Its a virtual tour to the place.

Oficial website

Not yet uploaded to main website. At this time is in

Any suggestion are apreciated


crashes for me :frowning:

it loads the config setting and gets to the screen with the jME and ODE logo, where it crashes

its running here.

WinXP, dualCore 2ghz, 2GB Ram.

looks kinda nice, but its impossible to get inside the building, right?

Have you used a prerendered AmbientOcclusion map?

Sbook can you give me more information about you computer? If you post the Java Console with the exception would help me to fix it.

.:emp…imm0|82:. Yes in outdoor scene the ambient occlussion is pregenerated in Blender. Sorry i did't explain the process.

To move the ExteriorDollyCam Clic+ move. Zoom Left Clic+ move

To Walk press Enter. You can Enter to buiding going to the door or pressing E.

To view the map press M.

In the interior if you select the option "Alta Qualitat" (High Settings) you activate the SSAO.

Sorry, I was in a bit of a hectic mode when I was testing this out.  I was on a 1st. gen Macbook Pro, OS X 10.5, Java 1.5, Core Duo 2.16 ghz, 2gb memory.

If you targeted for Java 1.6, that's the entire problem right there… I'll try running it again on monday and copying the console messages :slight_smile:

I did however, get to run it on a dual-quad core machine running Vista…  Ran just fine under Java 1.6.  Nice work, you guys are using this as a marketing tool for the school?

ah ok, walking around is much more interesting as just rotate around the building :wink:

nice work!

of course, there are still lots of thigs to improve but really nice for state of WIP.

keep up the good work…

sbook said:

Macbook Pro, OS X 10.5.7, Java 1.5, Core Duo 2.16 ghz, 2gb memory.

Same specs here and its having trouble loading ODE.

java.lang.IllegalStateException: No physics implementation was registered nor found!
   at com.jmex.physics.PhysicsSpace.create(
   at engine.states.FisicGameStatePass.<init>(
   at citm.states.Ingame.<init>(
   at citm.mainCitm.start(
   at citm.mainCitm.main(
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(
   at java.lang.reflect.Method.invoke(
   at com.sun.javaws.Launcher.executeApplication(
   at com.sun.javaws.Launcher.executeMainClass(
   at com.sun.javaws.Launcher.doLaunchApp(

I tested in a MacBook Pro and go fine… its strange.


It worked the first time but after that, it crashed when I tried to relaunch it. I'm at work, I use Vista, NVidia Quadro FX 1800. In the log, there is no exception.

It works here, but it takes ages to load! (Linux x86_64 with Quadro NVS 280 PCI-E) It looks fantastic though  XD