Webstart Problems


i’m at the early stages of learning JME and have come stuck at at few points involving Webstart.

i am struggling to get the program running in webstart. such as nothing happening after the splash screen.

one confusion i’m having is with the ‘signing’ part of the project properties under the webstart category.

the area has changed since documentation was made for it and there is no longer a straight ‘self-signed’ option.

in the customize button now offered, there are 3 options, do not sign, self-signed by generated key and sign by a specified key. which one should i be choosing? and will the ‘Mixed Code’ drop down have any impact.

if i choose the self-signed by generated key option, i get lots of messages about the key running out in 6 months when building,

another little problem is when i choose clean and build, it comes up with an error of ‘unable to delete file C:…distgame.jar’

any help on these problems much appreciated.

hmm was the edit button?

anyway, should have been dist \ or / game.jar (hopefully slashes appear this time)

tried deleting the file manually, and unable to due to it being used by a program. checked in processes and have 2 javaw.exe processes running. im presuming one of them is the game. ended them and the clean build worked so no problems there, except…

when i run the project from with inside JME SDK (3.0beta) i get the splash screen, then a quick java window with some bars downloading the files, then everything disappears.

Join the group to be able to edit your posts.

What does the Java Console say? Make sure the “Codebase Preview” URL matches with your upload location. And don’t check any other Application types. Compile only WebStart. Other Application types (like Applet) will override your self-signed jars.

These settings work for me:

1 Like

well i seemed to have Create Applet ticked, strange.

setup the signing just like you, except for codebase, set as Local Execution and pointing at the dist folder.

getting this weird warning message, not sure why but it slows down compiling time as it appears several times for different things


The signer certificate will expire within six months.

Enter Passphrase for keystore: Enter key password for nb-jws:

Signing JAR: C:/JMEProjects/Stomp2/dist/lib/noise-0.0.1-SNAPSHOT.jar to C:/JMEProjects/Stomp2/dist/lib/noise-0.0.1-SNAPSHOT.jar as nb-jws

i seem to be getting further but still unable to launch. get as far as the Select Display Settings window, then i press OK and the window closes with no game. launches when run as default config. any ideas?

on an unrealated topic, in XML, valign=“bottom” doesn’t seem to work, is bottom not correct?

Check the error output of the application, do you load any ogre models directly? They are not included in the distribution as you are expected to convert to j3o.

1 Like

only using a .obj model and sphere. not getting any errors, just says build successful. don’t even seem to be getting a javaw.exe process anymore in the task manger after the display settings screen.

same for .obj :roll:

1 Like

The Java Console is your friend:


1 Like

thanks for your help, got the Java console up, got an error,

16-Jan-2012 15:58:00 com.jme3.system.JmeSystem initialize

INFO: Running on jMonkeyEngine 3.0.0 Beta

Exception in thread “LWJGL Renderer Thread” java.lang.UnsatisfiedLinkError: no lwjgl in java.library.path

at java.lang.ClassLoader.loadLibrary(Unknown Source)

at java.lang.Runtime.loadLibrary0(Unknown Source)

at java.lang.System.loadLibrary(Unknown Source)

at org.lwjgl.Sys$1.run(Sys.java:73)

at java.security.AccessController.doPrivileged(Native Method)

at org.lwjgl.Sys.doLoadLibrary(Sys.java:66)

at org.lwjgl.Sys.loadLibrary(Sys.java:95)

at org.lwjgl.Sys.(Sys.java:112)

at com.jme3.system.lwjgl.LwjglAbstractDisplay.run(LwjglAbstractDisplay.java:204)

at java.lang.Thread.run(Unknown Source)

now as far as i can see i have jme3-libraries in the complie-time libraries which includes lwjgl.jar?

Hmm, I noticed that after cleaning up my user home, my own applet and web start don’t work anymore. Seems they only worked because the native libs were in place and now they are not correctly extracted. Have to check this at home.

There is this article showing how it works in all cases, but I thought it wouldn’t be necessary anymore.

1 Like

well well, it worked, when i was messing about early i tried adding the if statement from the page you linked about setting low-permissions. when i saw it it reminded me that i added it in. commented it out, and it worked.

thanks for all you help survivor and normen

i’m sure it wont be the end of my problems, but a good one to sort out. :slight_smile:

Lol, you just passed the problem on to @survivor :wink:

I had the same problem but I didn’t notice it because the native lib was already extracted in the Firefox program files folder. I think the deployment method described in this article has two advantages:

  1. The natives aren’t extracted to the browsers program folder but the jre handles it.
  2. only the os specific natives are downloaded => app starts faster (ok, neglible nowadays)

    @normen: Any chance we see this deployment method in jMP?

    And for the Applet: I was so uber smart to recursively delete “lwjgl*.dll; openal*.dll: bullet.dll” from my %USERHOME%, but I didn’t delete the JARs. So there is this directory “%USERHOME%\AppData\Local\Temp\lwjglcache\www.nabyrinth.com” which still contained all the JARs but not the natives. The lwjgl applet loader thinks: “okidoki, jars there, hash ok, no need to re-extract the natives” and … BÄM!!!


    Exception in thread “LWJGL Renderer Thread” java.lang.UnsatisfiedLinkError:

    Can’t load library: C:\Users\survivor\AppData\Local\Temp\\lwjglcache\www.nabyrinth.com\NabyBallMaze\natives\lwjgl.dll

    at java.lang.ClassLoader.loadLibrary(Unknown Source)

    at java.lang.Runtime.load0(Unknown Source)

    at java.lang.System.load(Unknown Source)

    at org.lwjgl.Sys$1.run(Sys.java:70)

    at java.security.AccessController.doPrivileged(Native Method)

    at org.lwjgl.Sys.doLoadLibrary(Sys.java:66)

    at org.lwjgl.Sys.loadLibrary(Sys.java:95)

    at org.lwjgl.Sys.<clinit>(Sys.java:112)

    at com.jme3.system.lwjgl.LwjglAbstractDisplay.run(LwjglAbstractDisplay.java:204)

    at java.lang.Thread.run(Unknown Source)