When I convert file .blend to .j3o it doesn't get all animations controll

I have a model made with blender with two animations but the problem is when I want convert the blender file to j3o. It doesn’t get all animations, only it get the animation that is active in that moment.

If the any ActionStrip isn’t active in that moment although The NLATracks are checked it doesn’t get any animation control.

This is mentioned here, under “animation”:

Ok thank you. Now I know that I need put an armature to get all animation.


I’ve got the same problem : only the animation selected in “Doop Sheet” is available in j3o (when I test in SDK).

  • I tried without armature (as my object doesn’t need)
  • I tried with an armature, single bone.
  • I check there are 2 Actions mark with [F]
  • I search in the forum, this topic is the best match
  • I read jme3:external:blender and I tried to follow it
  • I tried ogre exported (older forum Thread talk about it) with less success : no animations or python error on export
  • I tried to create a NLA track with the 2 actions (like in the video: blender to jme3 though ogre XML), but in this case none animations are available (like above)

versions: SDK 3.0.10 (official) + blender 2.71 (distro package)

I share my test file : anim_cube.blend, anim_cube.j3o

What I did wrong (I’m learning blender, jME) ?

The animation template in the SDK works, maybe you check what you do differently, normally the “F” button trick works.

I create a new “Basic animation example”, convert to j3o and notice the following :

  • Armature->AnimeControl : 1 action
  • Armature->Cube->AnimeControl : 2 actions (that seems to run)

Is is expected ? (in mt case I only have action on the Armature->AnimeControl)

When I open the .blend into blender 2.71 :

  • the animation doesn’t change the bone (like if there are no animation).
  • If I save a copy (I only tried to select/change active action) , then I convert to j3o => then there is only 1 actions (in both AnimControl).

about the last point, one of the action was not tagged [F], now both are available. I’ll investigate why I don’t have animation on the Armature->Cube>AnimationControl (tips welcome).

It would be easier if you were using the blender version that comes with the SDK to narrow down the issues. Just double-click the blend file in the SDK.

In the SDk “Open in blender” only minimize the SDK, but it doesn’t open blender.

missing some chmod +x on blender/blender (IIRC I had to similar change when I installed SDK some month ago)

I find the cause (I’m a noob in blender). I share my mistake + fix for others.

  • I transformed the bone and I inserted the keyframe in object mode. => only the active action is converted and only for the armature
  • transform of bone + insertion of keyframe in “pose mode” => active action is converted into animation of armature + 2 saved actions [F] converted into animations of cube (geometry)

Thanks Normen, the basic sample was helpfull.