Where can I find the assets used in the JMETests

I tried compiling the Test projekt that comes with the sdk, most of the assets are miissing… where do i get them and put them after i have them?

I also tried using some things from one of the tests that does have its assets, but i cannot find where those textures actually are to put them in my project. The JMETests project does not have an assets fodler or project.

I updated to the latest version btw

I read the Assets tutroeial its not that i cannot load things from a place i specify, rather that i cannot find the things used in the tests anywhere i tried searching for it on the hdd and got no result that way either.



Thanks for any help, im a little confused atm.

https://wiki.jmonkeyengine.org/legacy/doku.php/jme3:beginner:hello_asset

I tried explaining that i did read those tuts and that is not my problem i can lo0ad stuff i put in to my asset project perfectly fine, i can load other resources fine too. I cannot find the resources for the autogenerated test project, becuase they are not in an asset project. Even more some of the assets for the tests seem to be missing. because not all tests work.



And just to mention it again I DID read those tuts, and I did update the ide. I posted here in the hope that soembody could point out where the test resources are and where to get the missing ones.



An answer of one line seems a bit condescending to me, after i tried to be polite, and pointed out that i read those and that is not my problem.


http://www.youtube.com/watch?v=M1_0pbeyJzI

there is a library that the test project uses with all of its required assets called jme3-test-data.

you can add that library to your projects so you can use the test assets.

on my installation it is found under my jMonkeyPlatform folder at location: /jmonkeyplatform/jmonkeyplatform/libs/jME3-testdata.jar

1 Like

Thanky ou both. That solves one of my problems. The other is that many tests in the test project do not work because soem of their assets are missing. Where can i get an updated jme3-test-data library with the missing assets?



Furhtermore I have to apologize for saying the 1 liner didnt help. ITs right there in the green highlighted box. Funny thing is I tend to not register things that look like that because they resemble ad bars for me :stuck_out_tongue: SO it was right there but i was blind to it.

http://jmonkeyengine.com/nightly

may be there ?

I downloaded the latest nightly version, aded the test data jar from it to the project, most tests still dont work and are missing assets

Did you create a new tests project? The old project will still reference the old assets and thus maybe not work.

Yes i did create a new project, funny thing is many tests do work. Some of them just cant find their assets. Mostly the gui and terrain ones are affected. Most other tests work. Strangely when i look inside the test-data jar file all the stuff that doesnt get opened seems to be there. I also had to add the noise jar manually for the tests to even compile.