Why will this not deploy!?!?!

Okay I’ve done a way simple test case for you. This is an olllld version of JME 1.0 and a very simple game which runs fine in the IDE.

I’m linking a ZIP file that has a batch file, the main JAR, and a lib file with all of the JME things that I think I’m supposed to have.

Could somebody take a look at this and tell me why it doesn’t run?

Downloadable ZIP

Well it can't find it's SimpleGame class.

I suggest you take a look at FatJar if you use Eclipse, for simple cases it's kinda usefull.

Then melt everythin into that fatjar, and copy paste all needed native files in the same directory.

Btw this is how I arranged my files for my main project.


look list.txt for where the files belong

look/data for the files itself.

Or use http://empirephoenix.de/New_Horizons/Launcher/Launcher.jnlp if you want to lt the Update copy it to your drive in a working way.

But the SimpleGame class is in there with all of the others!

Also why do you only have 1 jme.jar when I have like 7?

I repackaged it, mainly because I wanted to have it compact, so only in one jar, also I was to lazzy to write that much stuff in the classpath. After all the GraficEngine won't change so often, that it really brings any gain to split it for me.

I find FatJar an ugly solution, but do like to keep jME in a single jar.

I also find executable jars a bit of a pain. You seem to have a slightly different classpath in the manifest. As an alternative you could try just running the main class diretly (java <package>.<class> instead of java -jar <jarname>).

But I want to deploy with a jar file. Are you saying I've misconfigured my classpath? What do I need to do to fix it?

You can still deploy it in a jar like that, but just invoke it differently - execute the main class within the jar directly instead of executing the jar itsef.

Still not working. Same problem. If the jme jar is right there in the folder, why can it still NOT find it?

I solved the issue!

By opening the jar file in my trusty old 7zip, I was able to drop jME's build files directly in! So I used the usual

java -Djava.library.path=./lib -jar MyJar.jar

along with dropping the JInput and all the other required jars into the library and it works! Hooray for me!

Basically the same that fatjar does, just copy all files inside it and done ^^

First I was thinking about not packing thema t all for my projct, sice that is kinda great ofr updates, you only need to change the files that are actually changed. But the Hd-acces and md5 generation for only the files in jme+a simpl tst appliation were already dozen times slower than package it into a few jars and in case of a change downalod the complete jar. (The main idea here is to optimize it a bit by sorting the , aka materials,models in one since they don't change often, my code in another and jme in another as well)

FatJar's  (manuall created or the way you did) have the great disatvatage, that for every change the jar has to redownloaded (at least if you don't use a Java web-server, I heard they are able to create patch files on the fly)