WidgetText not well

Hi there.

Long time since last visited.

Have anyone lately tested the WidgetTest’s because something is

not well with the text being displayed. I think it can be something to do with the new GUI system.

Can one of you developers please have a look, because I’m

kind of using the widget stuff?



Please?

There shouldn’t be anything changed in the widget library. The GUI stuff from Guurk is external to it. Can you describe your issue in detail?

I’ve just run the widget test : I’ve got a problem with widget too.



All the labels are not readable they are replaced by a white or a black rect with the size of the text.

I’ve tested with the CVS version : there’s the problem

I’ve tested with the 0.6 jar (same lwjgl version) : it’s ok



There’s no exception in the log.



i’m under linux, geForce TI 4400, AMD Athlon



bye,



Adenthar

sounds like the texture is missing.

If it means anything, I’ve gotten the same results from the widget test in CVS for a very long time. I figured it was just me.

That is exactly the problem I got. I’ll hate to lose the usage of widgets, it kind of rocks!

It’s probably a state issue. I’ve had the same issue in the past when something was messed up on my state like zbuffer, texture, lighting, etc. I’ll have a look in the morning and see if I can’t clear it up.

Hmm, so after an hour or so of looking at this issue, I know for certain that the texture and alpha states are there and being applied… The texture itself is correct (I saved out the bytes being applied and pulled it into photoshop as a .raw image successfully), but for some reason the states are having no affect. I tried applying a few other states with the same result.



The problem tracking this down is that the widget stuff does not follow many of the conventions of the rest of jME (which is why I personally went with the newer gui stuff in my own game.) Makes it very hard to track down exactly what is up… But even using a debugger and following the code execution, everything seems ok, just we are only getting colored quads, no states. :frowning:



I’ll keep looking.

Ok! So the issue was involving the texture, however it was not the image, it was the texture’s settings, specifically mipmap. It was set to MM_NONE. Setting it to MM_LINEAR allows the text to show up once again.



One issue I see now though is that since the old widget stuff does not use the renderqueue, it draws before everything else and ends up falling behind other scene objects. I’ll check in the fix I’ve done for text and then see if I can fix this issue as well.

Hmm, after a quick run through, it does not seem to play nicely with renderqueue… probably some unimplemented methods or something. I’m not sure how much people care about this, so I’m not going to put any more effort into this unless requested.



I was able to get some results adding a zbufferstate, but the font graphic used is funky and doesn’t play nicely with the alphastate required to go with it (ends up with jaggies around the edges.)



Hope the text is good enough for now. :slight_smile:

Thanks a lot for your time. It is create that you fixed the text problem, although it would be nice if the other widgets can also be fixed. These thiks are really powerful for usage in layouts, etc.

What’s wrong with the other widgets?

FYI: Slider graphics are fixed now.

This is a fixed issue. If you had to change MM_NONE then you don’t have the latest version from cvs.