Windows .exe and Mac .app - Changes in Beta?


after solving some other problems yesterday, i want to build my Projekt.

I mean build the .exe and the .app, it worked, no error. But if I start the exe i get the blackscreen and exit after one second.

Same with the .app on my Mac.

I can run the Projekt via F6 or the “play” button, without errors!

Why i can’t start the exe from the /dist/ ? Any changes with the update (alpha → beta)?


Not really, try disabling the deployment options, press OK, then open the settings again and re-enable it.

No don’t work BUT i run my .jar via CMD an i got an error that my player.obj is missing, but i can start it in the SDK … maybe some things aren’t exported? :smiley:

.obj models do not get exported for deployment as you are expected to use .j3o models and only use the original models during production. This is configured in the project assets settings.

1 Like

ok you mean i should test it with the the j3o and the import source “Models/player/player.j3o”

nice, it fixed it