Windows executable error

So after a long time i decided to clean and built my/our project, but when i start the windows exe i get

an error that says something about a read error in a specific memory location (german language,so i tried to translate).

all libs that are used are inside the jar or lib folder that gets compiled (automatically).

any suggestions?

I know it’s a stupid question, but have you verified that it has indeed built without error? It happened to me that I started the build process, went to make a coffee then ran the build that crashed… Only to find out the built hadn’t succeeded. Not proud to say it here but there it is. :stuck_out_tongue:

The error you describe sounds like a native crash, which should normally only happen when theres general issues with the operating system and/or graphics system/drivers.

built went without any errors.

well, i/we took four different machines to built. same error for everyone but the mac, where it also crashed on start.

it worked without a problem a few weeks ago, but not anymore :frowning:

Well it can happen that compiled file still had old code and the new code was never compiled. Then when you press clean&build it does get compiled new and suddenly you have errors. Its best to clean&build after every major code change. Try disabling especially effects that you added lately.

managed to get it to run last night. for the ones that are courious, or have same problems:

  1. somehow all the dlls of lwjgl where missing and had to be copied manually into the jre directory.

    (i had the jre and the sdk of java installed, but none of them had the dlls in them, is that normal?)
  2. the skybox/cube that comes with jme3 examples did not work with nvidia cards and caused exeptions.

    solution= build your own skycube (dds) with the nvidia plugin for photoshop, or open the existing ones and save them again with the right parameters.

    i´m so happy right now :slight_smile:

The dll’s should never have to be handled and definitely not copied in the global lwjgl directory, they are extracted automatically.

then how come i had to do that?

edit: what gets extracted on first run of the exe are two dlls ljwgl and openal, but somehow the program

seems to look for them at the wrong place i guess

Maybe you copied the file to a directory that hasnt got the correct user rights?

it seems like it really only was the dds file. removed the dlls from the jre/bin folder and it still works.

strange, that the skybox/cube is hardware dependant and crashes the whole game. is that a known issue?

Its rather software dependent, most “fixes” in the shaders are workarounds for bugs and non-standards in nvidias and atis OpenGL/SL implementations. Are the drivers on those machines up to date?

drivers are the latest stable ones. dunno whats different with the compiled version, cause the skycube works out of the platform. veeery strange. well, the skycube i made works on my machine, but not on another one having a nvidia card also. damn…

Is there maybe a mix of OpenJDK and Oracles JDK installed on the machines?

oracle only. is that a problem?