Winodow 10, Eclipse, JME won't launch silently[Solved]

So we currently have a bizarre problem on windows 10. We can compile no trouble and everything looks good. We are using the latest JME from github which as i said works fine on all other platforms and ALSO works fine in windows as an exported JAR.

However when we run our app or any JME app, it just terminates at app.start() without any messages, errors or anything. We even set Logging to ALL and still no messages.

Even stranger if we export the project as a runnable Jar will all dependencies repackaged into said jar. Double clicking on the resultant jar works perfectly.

I realize diagnosing this is very hard since there is just no messages. But i am at a loss and need help/suggestions.

Note that the JME was built on linux with Zero issues.

Any help would be Awesome… and if i ever finish this game, gets free steam keys. :smiley:

By this do you mean when you run the SDK packaged “Desktop app” or whatever that makes an exe for you?

I never got this to work either on any Windows version I run. I ended up downloading Launch4j and using that instead.

1 Like

Sorry not being clear. I mean running a JME app from inside eclipse with a launch configuration, that is right mouse clicking on java source file and going Run → Run as java Application.

Exporting a runnable JAR works Perfectly.

The problem is there is no errors. No message no nothing in the console. It just terminates.

Oh, sorry… I know nothing about eclipse. Sounds like a classpath/working directory issue. Like the shared libraries aren’t extracted properly or something.

1 Like

That would typically result in a message “such and such no found”.

Also then it wouldn’t work packaged. Since it using identical classpaths.

In many many years of java development i have never seen anything like this. I always get a crash, a link error, a segfault, a “not found” or something. Never nothing.

Wouldn’t that always result in an UnsatisfiedLinkError though?

This is probably a long shot, but on Linux a JVM crash will produce a log file of detailed info. I have no idea where such a log would be produced on a Windows VM, but if you could locate a crash log it might give you some idea about what’s going on. I use Eclipse with the Buildship Gradle integration for my Java/JME projects. I haven’t used the Eclipse Java Builder in forever, but I find it very surprising that you’re getting no information at all - Eclipse (at least, with Gradle) is usually very good about giving some helpful information, so the lack of information makes me suspect a very low-level (and early) failure, hence my suggestion to look for JVM crash logs.

1 Like

Interesting will check for something . We had some issues with gradle on windows. Mostly because I am not setting it up. But my brother is. In fact i am a linux only user for the last 13 years (i think).

But gradle in eclipse does sound interesting and we are intending to eventually use gradle as the build tool. But have had no particular need at this stage.

Wow, I’m a Linux-only user too, but not for 13 years. :wink:

Gradle is very, very powerful. If you’re using it for “out of the box” uses, it’s pretty easy to get up and running. More advanced stuff has a pretty steep learning curve though. I love it because I get “cross platform” builds for free - no need to install or use a particular IDE, and no need or reason to have IDE-specific config files cluttering up my repo.

For anyone interested. We have narrowed down the problem to Swing and AWT. Yes. For some reason JFrames will not show and it silently closes the app with no messages.

We have now fixed it. In this case this release of the new Nivdia driver did the trick.