Working with Eclipse

Hello all. I just started to work with jme-physics and have a question. I can get the snapshot version of beta 2 working but I would like to work with the current version on the cvs. However, I cannot seem to get it to work with eclipse. I either get an UnsatisfiedLinkError for odejava when trying to run the test-interactive folder within the jme-physics folder or this error message:

java.lang.IllegalStateException: Geom with native address 0x3e74580045b4570 not found!

if I create a project that references the cvs projects.

My real question is could someone give step by step instructions for setting up jme-physics in eclipse for both working within eclipse and creating jar files for later use.

Any help would be appreciated.

Setup for beta2 and cvs version should be the same. The error message you posted does not seem to be caused by a misconfiguartion. What platform do you run it on? (OS?, 32/64bit?)

That sounds like the java.library.path is not set in the Build path of your Eclipse project. You'll need that to point to the dir of your ode C libs. I normally place all libs in one directory and point the java.library.path to that.

Ah. Was doing two things wrong. One, forgot to set the java.library.path like you said Fuzzy, and two I wasn't using the latest libs that are in the cvs project but grabbed those from the snapsnot. Why I was getting the geom error it seems.


Thanks guys.

I got some problems creating a running project from cvs with eclipse.

10: package jmetest does not exist

    [javac] public class TestChooser extends jmetest.TestChooser {

and 5 more of those.

I have a running cvs version of jME, does it need some file or can I link some jar to it.

I used the build.xml and wanted to build some jars from it.

jME Physics 2 tests need the jME tests in the classpath.

First sorry for posting toubles.

I added jme/bin/jmetest as class folder but it did not change a thing

<classpathentry kind="lib" path="/jME/bin/jmetest"/>

<classpathentry kind="lib" path="/jME/src/jmetest"/>

this is the complete output:

Buildfile: /home/sue/workspace/jmephysics/ant/build.xml


    [echo] using jME base dir "/home/sue/workspace/jME"


  [delete] Deleting directory /home/sue/workspace/jmephysics/classes




    [echo] using jME base dir "/home/sue/workspace/jME"


    [mkdir] Created dir: /home/sue/workspace/jmephysics/classes

    [javac] Compiling 36 source files to /home/sue/workspace/jmephysics/classes

    [copy] Copying 5 files to /home/sue/workspace/jmephysics/classes


    [javac] Compiling 10 source files to /home/sue/workspace/jmephysics/classes

    [javac] /home/sue/workspace/jmephysics/test-interactive/com/jmetest/physics/ package jmetest does not exist

    [javac] public class TestChooser extends jmetest.TestChooser {

    [javac] ^

    [javac] /home/sue/workspace/jmephysics/test-interactive/com/jmetest/physics/ package jmetest does not exist

    [javac] import jmetest.TestChooser;

    [javac] ^

    [javac] /home/sue/workspace/jmephysics/test-interactive/com/jmetest/physics/ cannot find symbol

    [javac] symbol  : method start(java.lang.String[])

    [javac] location: class com.jmetest.physics.TestChooser

    [javac] new TestChooser().start( args );

    [javac] ^

    [javac] /home/sue/workspace/jmephysics/test-interactive/com/jmetest/physics/ cannot find symbol

    [javac] symbol  : method find(java.lang.String,boolean,java.util.Vector)

    [javac] location: class com.jmetest.physics.TestChooser

    [javac] find( "com.jmetest.physics", true, classes );

    [javac] ^

    [javac] /home/sue/workspace/jmephysics/test-interactive/com/jmetest/physics/ method does not override a method from its superclass

    [javac] @Override

    [javac] ^

    [javac] 5 errors


/home/sue/workspace/jmephysics/ant/module_physics.xml:75: Compile failed; see the compiler error output for details.

Total time: 3 seconds

You can do at least two things. 1) Change your reference from jME/bin to jMe/build or 2) Build the full jME project and reference the jME jar files in your project classpath. Have fun!

I have already build and jared the jME files and linked them as library, butthis won't do it.

hitting the table

OK problem solved. I never build the jmetest classes manually because I never needed them. I now created a jar for jmetest and now everything worked.

Eclipse never mentioned that the required class files are not there so I never looked.

thanks anyway for the help maybe I write a howto build jmephysics with eclipse.

regards Sue