Xbuf format – A developer friendly game exchange format for 3d data

Is there any chance that model imported with xbuf format would work in jme 3.0?

Today, xbuf dev are based on jme 3.0.
But xbuf model could require xbuf runtime classes (Controls for animation, skeleton, light orientation). Thoses classes are part of jme3_xbuf_loader.jar, I can extract them is an other lib if it’s required required.

We are able to use 3.1 for importing purposes, but it should be great if the final j3o would run on 3.0
Or if there is no other way, the additional lib would be a nice solution too.

today, I didn’t test xbuf against 3.1 (I “backport” SkeletonControl). the lib is also required after xbuf -> j3o (due to Controls).
Maybe some controls could be removed in future (I used some to ease data manipulation that could be replace by preprocessing) or integrated in core.

So I understand that we need an extra .jar anyway. No problem.
It is great that you started the xbuf project, big thanks to you, because importing something more complex than testrobo is just a nightmare. I was completely broken wen I heard about @winhelp 's troubles…

Thanks, but import of testrobo has some issues. I started the assimp3xbuf project to help me find if the issue is in the format, the blender export, the jme importer. I learn a lot…

I also use your “spider” model for test.

I don’t know if this is important, but our current research gives us some information about exporting to ogre. It looks that the issue lies in blender2ogre, because all animations, including the messed ones looks exactly the same in ogre viever tool and in jme’s sdk.

I study some existing blender exporter to see how they export, I didn’t see all the subtility. And as I’m not a blender expert or animator, I didn’t see lot case. I try to list them and reproduce them into xbuf_unittest.blend.

Do you have the same issue than winhelp : nothing displayed with the last ModelViewer and the last blender_io_xbuf plugin ? (If you tried it) http://www.xbuf.org/get_started/

We are with @winhelp in one team. So every issue he reports concerns both of us.

Now I want rebuild spider rig (maybe its too complicated) so be patient :wink:

Sunday, I’ll be able to test on a fresh windows 10. (I’m developing on Linux & macosx) I hope to be able to reproduce your issue (I tried to use cross platform path,…).

Can you launch blender from console (dos) and report the console when you try to display the model ?

Thanks for your help.

I keep all version of your .blend, at the end nothing should be too complicated or at least the exporter should warm/advice the artist.

Here you go: http://wklej.org/hash/97874a1d0a1/

going to sleep, bye :stuck_out_tongue_winking_eye:

1 Like

@winhelp, thanks, I push a quick fix, so you can tried one of the following solution :

  • redownload a update (master) of blender_io_xbuf : Download ZIP
  • create manually the default assets directory : C:\Users\user13\assets’
  • choose an existing assets directory (uncheck relative path in Blender file selector) in ‘render property panel > xbuf > assets_path’

The issue is that python Path can’t be resolve on inexistant path.

It works! :slight_smile:

Oufs, thanks for the update and your feedback

Oh, and if you need more models to test with, I’m sure @Kaelthas has received many “troublemakers” to test with over the years. Maybe he’s still got some of them lying around.

Here’s our base model: a low poly human generated with makehuman v1.0.2

The objects (Body, Eyes) are on layer 4, the skeleton is on layer 2.
Lights are just to see the model in blender. We don’t use them ingame.

This version does not have animation. Let us know when you need an animated version.
Here’s the zip containing .blend and textures: https://copy.com/6vfhwtL1rdMvg0RH

@zanval, Thanks I include your model into my samples directory.

2 Likes

next 10min stream today at 20H UTC / 22H Paris (in less than one hour)
I’ll try twich again : http://www.twitch.tv/davidb31

  • show unittest
  • show testRobo, Jaime and do a point on animation support

boring video available at :

2 Likes