Xlib error while opening the game

Sometimes,when i join the scene in my game (not when i start the application,when i stay in the menu it runs) an error appears and the application crashes without popups.

[xcb] Unknown request in queue while dequeuing [xcb] Most likely this is a multi-threaded client and XInitThreads has not been called [xcb] Aborting, sorry about that. java: ../../src/xcb_io.c:179: dequeue_pending_request: asserzione "!xcb_xlib_unknown_req_in_deq" non riuscita.
(Last message about native file is in italian,sorry about that).
This happens since i switched to JDK 8,did anybody have the same problem?

OpenJDK? Try the proper Oracle JDK.

No,i use jdk 1.8.0_40


I am having this same problem, did you solve it?
It doesnt happen all the time tho, seems random.

I found this tip http://theindiestone.com/forums/index.php?/topic/1044-damn-you-linuxjava/#comment-15829
We would have to create a lib and load it to prevent this problem. That seems too much, but may be the only option?

PS.: It happens only on linux.

Sorry,i think i solved the problem but i don’t remember how…probably some java update fixed it.

1 Like