Zoom not working properly

Hi,



I am trying to zoom to a mesh in my level but since i added another big terrain

i cannot zoom properly to the castle mesh because it’s too far away,

it looks like the zoom is not powerful enogh, is there a way to set the zoom power?

Forgot to say that i work in the scenecomposer

You mean that you have z buffer precision issues?

I mean that when i click with the mouse to zoom the model doesn’t get near

Your model is just too tiny… You won’t have much fun with it in-game either unless you change your frustum settings and basically any kind of scaling for things like water, physics etc etc. Just consider 1 unit = 1 m and most things will work best.

yet i dont get it,

when i load the model everything is in the right dimension

Relative to things of the model, sure. But if you were shrunk to sub-atom size including your car that you sit in I could also zoom in with my eye as much as I want and not see you, still you would be correctly sized in relation to your car.

aaah i got it

thank you Normen always super useful!

I Finally discovered the root of the problem

the zoom button is not working my monkey sdk

what could be the root the problem???

The wheel of the mouse is working

Well you can only zoom in to the cursor, all the way up to zero distance. To move the cursor keep the right mouse button pressed. The cursor is the virtual spot in space that your cam rotates around.

I will reinstall it i am going mad with a lot of strange problems,

and the model worked well on my friend pc…

If you have lots of strange issues, try using the “Heavyweight Canvas” through the OpenGL settings of the SDK.

Hi Normen,



i will try it this evening i didn’t know about the existence of it,

by the way yesterday i reinstalled and it was working perfectly.