Hi, think there may be a problem with zorder

I modified the TestRenderQueue demo to check the zorder of quads.

I found the the setZOrder method didnt matter - what did was the order they were attached to the node.

try attaching q2 before q1, q1 which should have been partially obscured by q2 is now on top.


If rendering say 3 box's, one red, one green and one blue. Each have the same dimension and the translation can the zorder be used to set which one is on top or is zorder for ortho only

What you are saying is true if the renderqueue is not being used.  You do know that RenderQueue is not enabled when you start the test, right?  You have to hit 'Q' to turn it on.  Doing so and altering the test showed the proper results still when queue is on (q1 should be on top of q2 because q1 has the lower zorder)  As for your other question, zorder is only useful for ortho mode, transparent and opaque modes use distance from camera to sort.

Sorry - my mistake, things working as designed…

Cool beans.