3.1 Android ParticleEmitter culling?


I’ve made a particleemitter which i load in a 3.1 application. Looks good in scenecomposer and desktop, but it seems to be frustrum culled when on android. Ie, it’s sometimes shown, sometimes not when moving the camera around.
Is this a known issue? I’ve tried to manually set the bounding volume to something large, but it doesn’t help.

Adding a skybox solves the problem. I can’t say why, though.

maybe the root node is culled out, and adding the skybox makes it wider and you never get it culled… That’s strange though.

To add further information:
Both the cam and scene are static at 0,0,0. I just turned the camera around. I had also tried moving the particle emitter to different positions to see if that helped.

Are you using Point particles by any chance? E.g.

ParticleEmitter emit = new ParticleEmitter("Emitter", Type.Point, 10000);

Can you reproduce the issue with any of the tests in jme3test.effect?

I’ve tried both.

I tried to reproduce with TestMovingParticle, but it works fine.
In my own app, the skybox (not the particle emitter) also fails to render on its own. But when both are added, it works.

Any chance you can make a test case?