7 DoF robot arm from blender 2.75 to JME 3.0

Hello everyone. I’m actually new in 3D modelization, and I’m wrking on a robotic project which is consisting of making an interactive web application wherein a user can manipulate a virtual arm.
By saying “manipulate” I mean that the user will be able to select a mesh (link or joint) and insert the degree of rotation. The model will rotate according to the user input. The arm in question is a 7 DoF robot arm and gripper. I’ve been able to create le 3D in blender (the rigging, armature and all stuff) and I want to import the .blend file into JME, to do the manipulation and the interactivity. I’ve followed this tutorial http://wiki.jmonkeyengine.org/doku.php/sdk:model_loader_and_viewer, the “Using the model files directly” section (since I used Blender 2.75), I succeed to load the blend file but the result is a little messed up… Actually all the meshes (10 meshes) are located in the origin, I mean it’s like when the meshes’ location are (0, 0, 0) which is not :confused: I’ve been googling during two days and haven’t find any solution :cry: I hope you got the idea. Any ideas well be wellcome. I’ll be grateful. Thank you in advance.

Did you apply transforms in blender?


There was strange things happened tome too. I animated a make human body in blender and imported .blend to jme. Animation was not imported properly. some bones dose have animation
but some other doesn’t have. Animation was a jump animation that I loaded from a BVH file.
Then i tried to export it to ogre XML. and every thing worked fine.
Also make sure that there is an origin bone and other bones be child of it.

Create a origin bone named “root” and always apply trasforms in mesh and bones.

Yeah, actually I get this result after I applied transformation on meshes and bones, and I noticed that after appliying transformation all the meshes local frames become at the origin. So I wondered… may be that was why all meshes are located at the origin after importing blend file in JME, so I undid the transformation and get the same result… all the meshes are in mess

@Ali_RS I wated to export my blend file to ogre XML, but I didn’t find tha appropriate add-on for Blender 2.75. And about the parent bone I’ve actually done it since the arm is composed by:
the base → joint Rot (z) → joint Rot (x) → joint Rot (z) → joint Rot (x) → joint Rot (y) → joint Rot (x) → joint Rot (z) → fingers, and so the bone attached to the base is the root parent of all the other bones

blender2ogre is a good add on for exporting ogre xml . please check here.

I already checked, there is no version for blender 2.75. The latest one is for blender 2.69 :sob: thank you for replying so fast

Do not worry. It works fine. Now I use blender2.75 with this add on .

1 Like

oh! Great!! So you saying I export my file to ogre XML and import the resulting xml files in JME… I’lle try it and make you know… Thank you very much… I really appreciate it

Your welcome my friend.

@Ali_RS I installed blender2ogre add on in blender, and extported the the project to Ogre 3D, the result was the creation of 08 xml mesh files (since I have 8 meshes) a .scene file but no xml skeleton file :confused: weired isn’t it? I do not have a material file either, but I think it’s ok since I didn’t put texture.
May I go on or is there somethink else I should check befaure I continue

Is “export animations”/“export skeleton” or something like this checked in the exporting window? There’s a page in the wiki that tells you exactly how to export animated models from blender.

My friend first check to see if the follow option is enabled in your blender?
File → User preference → File → auto run python script
if not please enable it then retry again. if there was no skeleton file . reply again so we try to solve it.

Some tips:
First select the whole mesh you want to export .(by pressing B button you can do this)
in export menu make sure Armature Animation , export materials is enabled.
set swap axis to xyz.(this is because the axis direction in blender is different from jme).

Oh I forgot the most important thing.
I think the reason there is no skeleton is because there is no armature modifier added to your mesh.
please make sure you read “Creating assets in Blender3D” in JME help menu. (by pressing f1 in jme).

you are 100% right! And it worked!!! :smile: Thank you very much gys… This community is the best

I got another issue now… I think that I should have basicly one and unique mesh groupping all the arm components but each compenent has to be independatly attached to a bone (parent-child relation).
So how could I have one global mesh (groupping 8 independant mehses)+ one armature (8 bones each one parent of a single mesh)

First select child hold shift and select root bone . then pres ctr + P . a menu will pop up. there are some options . I my self am not sure about difference. but i think you should play with 2 last options.
After you done with your bones . now you should select your mesh then select root bone and press ctr + p here i think you should press "with empty group " in pop up .(I’m not sure).
For more info please search videos for rigging in blender.

If you’re saying that I should parent bones it is already done. root bone is parent of bone1 and bone1 is parent of bone2 and so on… Then robot base mesh is parented by root bone, mesh1 is parented by bone1 and so on… I followed a very good video tutorial about assembling and rigging. that’s the link Rigging an Assembly Line Robot - Part 2 on Vimeo

In which mode? edit or pose?
anyway thank you for your reply

Hi, butting into the conversation :grin:

As I understand it you are getting multiple meshes upon export right? In object mode select all of your individual meshes and press ctrl-J to join everything. Than export as one mesh. Joining the meshes shouldn’t mess with the vertex bone weights, but making a backup doesn’t hurt

1 Like