(a different) problem with HelloModelLoading


first of all thanks for creating jme and the tutorials! great work, guys!

i’m using a recent cvs-version with eclipse 3.1 under linux and i’m currently going through the tutorials in the wiki http://www.jmonkeyengine.com/wiki/doku.php?id=learning_jme.

the tutorial-code i’m using is from cvs since the code in the wiki seems to need some tweaking here and there to run with a current version of jme.

when i run HelloModelLoading i get the following error:

Damn exceptions!java.io.IOException: Header data doesn't match
java.io.IOException: Header data doesn't match
   at com.jmex.model.XMLparser.BinaryToXML.readHeader(BinaryToXML.java:305)
   at com.jmex.model.XMLparser.BinaryToXML.sendBinarytoXML(BinaryToXML.java:101)
   at jmetest.TutorialGuide.HelloModelLoading.simpleInitGame(HelloModelLoading.java:85)
   at com.jme.app.BaseSimpleGame.initGame(BaseSimpleGame.java:449)
   at com.jme.app.BaseGame.start(BaseGame.java:56)
   at jmetest.TutorialGuide.HelloModelLoading.main(HelloModelLoading.java:63)

i tried to create the url as mentioned in the other thread concerning HelloModelLoading (http://www.jmonkeyengine.com/jmeforum/index.php?topic=3338.0) but the result was the same. when i give an obvious false filename i get a NullPointerException so it seems, as if it finds the file. if i would have found a different combination of obj/mtl files, i would have checked if it works with them, but google was not my friend this time. :(
any ideas anyone? and thanks for your time. :)

There are some issues with model loaded in latest cvs as the loaders have been changed to a new format. Are you using latest cvs? If yes this might help you:


It will be fixed the next couple of days.

yes, i'm using latest cvs. i will than use jme-models until a fix is committed to cvs. that should be sufficient to toy around a little. thanks a lot for the quick reply!

update: fixed! as said elsewhere, damn, you guys are fast! :) thanks!