About code style

Hi,



I have a question…



There is a method in the class com.jme.math.Quaternion.


    /**
     * @return true if this Quaternion is {0,0,0,1}
     */
    public boolean isIdentity() {
        if (x == 0 && y == 0 && z == 0 && w == 1)
            return true;
        else
            return false;
    }



Why authors did not write it as


return (x == 0 && y == 0 && z == 0 && w == 1);   ?



Is this for readable-code or this is mistake?

readability probably…

less code doesn't mean it will run faster :slight_smile: