Adding JME3 sdk to Android Studio

Dear, I made a project on Android studio that contains all the needed classes i want for a game i am making such as the login, gps location and motion detection classes etc. I want to port jmonkeyengine sdk to android studio so i can continue making the game built on the jmonkey engine, and i don’t need the nice tools found in the jmonkeyengine ide since i am making my own classes for it. is there a reference on how to do it since i only found about porting jmonkey to eclipse and tried somethig similar with no success. thanks in advance

1 Like

Hello, sorry about the delayed response, i followed the instructions for adding the jme sdk to android studio in the page you sent and everything went well. I added the sdk and its imported successfully but when i add androidharness and use it the app crashes with an error about swing or java.awt. how can this be solved since in the tutorials i saw, creating a project is always related to jme IDE

Hint: if you include the exact error then perhaps hundreds of readers might potentially have ideas. If you don’t include the actual error then you are gambling on that one person that might have had exactly the same sequence of events and can already guess the error.

It’s not roulette. You don’t get a bigger payoff on the longer odds.

1 Like

sure thing, sorry about that. I was writing the reply on my mobile, I will post the error when i get back home

Android doesn’t have awt or swing, simple as that. You can’t use the jme3-desktop and jme3-blender packages on android.


thanks for the response, the jme3-blender and the lwjgl libraries were responsible for this error. Removing these libs fixed the issue

I am looking for the same thing. However, the link with the solution posted by normen (Core Developer) is not available anymore. Could someone please help me. I want to use JME with Android Studio?

Well, Normen was just being nice and proving the wiki link that is at the top of every forum page. The target of that link has changed but it’s location has not… so you can find it easily by scrolling up.

hello, even the link won’t help you anymore lately. The gradle repositories link is not available the last time i checked. You can download the old 3.0 jme libs from this link Dropbox - - Simplify your life, then place it in the libs folder and link it to gradle as a local lib. Also before releasing your product, add the default assets in this link, to your assets folder Dropbox - - Simplify your life so you won’t have an issue in release as it happened to me when i switched in gradle multidexenabled from default to true upon release.

this web page is down. can you give a description of how to use jmonkeyengine in android studio

You shouldnt have to scroll to the top anymore. The links should be static at the top of the page, though when i fixed that issue, i didnt fix it for mobile. Im not sure there is enough room for them.