Advanced JME Binary Convert crash

I seem to be getting this for every time i use this lately:


at com.jme3.gde.ogretools.convert.AdvOgreXMLConvertAction$

[catch] at

I’ve tried unchecking the various options and also tried without creating lods, with the same result.

Regular j3o import works fine, though.

Oh, it crashes like this when theres no material file, I should add a check.

That would be excellent! Thanks.

You should be able to just add some empty file and name it mymeshname.material


i know it’s old topic, but i have similar problem. “Convert to j3o binary” work perfect, but

“Advanced JME Binary Convert” just do nothing.

Yes i tried “mymeshname.material” and with “Convert to j3o binary” worked with no exceptions, but still “Advanced JME Binary Convert” dont worked.

I have no informations, no exceptions doing it. it just do… “nothin”.

It worked 2 times for me(and on some i had just “Exception” word in output(but popably becouse of material name)), but on most objects “mesh.xml”(becouse i useit) it dont work(it just do nothin - no exceptions, no processbar). Is there any place i can see logs of it or somethin?

I tried to restart JMP many times, but it don’t help

Please help me becouse i want to create tangents to use normals :slight_smile:

ahh now i seee exception and i understand why i had problems :slight_smile:

java.lang.IllegalArgumentException: Can only generate tangents for meshes with texture coordinates
at com.jme3.util.TangentBinormalGenerator.processTriangles(
at com.jme3.util.TangentBinormalGenerator.generate(
at com.jme3.util.TangentBinormalGenerator.generate(
at com.jme3.gde.core.sceneexplorer.nodes.actions.impl.GenerateTangentsTool.doApplyTool(
at com.jme3.gde.core.sceneexplorer.nodes.actions.AbstractToolAction$1$
at com.jme3.gde.core.sceneexplorer.nodes.actions.AbstractToolAction$1$
[catch] at
at com.jme3.gde.core.scene.SceneApplication.update(
at com.jme3.system.lwjgl.LwjglAbstractDisplay.runLoop(
at com.jme3.system.lwjgl.LwjglCanvas.runLoop(

so i just forgot about texture coords apply in blender(i dont known it need it, i thinked if there are no tex coords then it will create it :))

but this exception i only see when i do "Convert to j3o Binary" and i do on geometry "Tools -> Generate Tangents"
but when i do "Advanced JME Binary Convert" then it show nothin so i just dont known what going on :)

So thank you for help :) And sorry about my blind with exception description :)

The Application Output window is where you see what happens, errors appear as little warning signs in the lower right. Advanced import does not work on Linux as theres no OgreConverter binary for Linux available. You can generate tangents on any geometry by right-clicking it in the SceneExplorer.

Btw, I finally added the fix I promised here ^^ Added a check and warning for missing material files when Ogre files are loaded and also changed back the “File.mesh.j3o” name created after importing OgreXML files to “File.j3o”.