Android & Lemur/jME not cooperating

Disclaimer: this is more a ‘I don’t know how to fix this and don’t know an alternative’ thread than a ‘I need help’ thread

Hi everyone,

as you might or might not have noticed, I had some minor issues with my Android app lately.
The app is a hexagonal map editor. This means I need:

  • some way to let the user place a tile (done)
  • some way to let the user describe what kind of tile they want to place (half-done, uses Lemur)
  • to save the file, which needs:
  • a way to save/load the scene (done, uses self-made language)
  • a way to save files on Android (done)
  • a way to let the prompt the desired file path (not done)

The last thing (prompting file path), might seem easy, but I couldn’t make it work.
The first that came to my mind was using Lemur’s TextField. However, tapping on it does not open the keyboard, so I manually used JmeSystem.showSoftKeyboard(true) to open it. This made the keyboard appear, but the TextField gave no response. I tried it again on my emulator (API 25), and the TextField did seem to respond to my ‘real’ keyboard.
So I tried again on my phone (same apk build as in the emulator), and I found out that most characters don’t do anything, but the ß does. I played around some more, and found out that almost nothing on my usual keyboard works. On my code keyboard (I use it for QPython), most alphanumeric characters work, but brackets and other similar characters don’t.

This is strange, but I think it has something to do with the difference between what Android keyboards can send and what the AndroidHarness can translate to input events.
What needs to be done to fix this?
Or else: How do I bypass this problem?

Note: Lemur is using JME’s RawInputListener which is the lowest level listener that JME provides.

Point being: for testing this at the lowest level, you can register your own RawInputListener with the InputManager to see what exactly is coming through… then trace back from there.

I’m facing the same problem now with my Android app. most characters work fine but control characters not (back, delete, selection for copy paste etc.)
Can you share what was your solution? I really want to use Lemur’s text rather than regular Android text field

Thank you

I don’t know for others, but delete (if you mean backspace) is fixed on 3.2. (or should)