Animation axis translations problem

Ive been trying to import a item for a game, but the axis translations of the animation where all off.

This is a test case i made:
The left shows the original animation, where i move the box in each direction in turn
The right shows the result in the SDK after converting to j3o.

This was converted directly from .blend to .j3o using the SDK.

Rotation still works ok.
X direction in blender moves the box in the Z direction. (which is correct)
Z direction in blender moves the box the X direction in the SDK. (should be the Y)
Y direction in blender moves the box in the Y direction in the SDK(should be -X)

that explanation was a bit confusing because of blender and the SDK using different co-ordinate systems.
I have checked for updates, am not on the nightly build.

Help much appreciated.

In blender z points up, y points away from you.

In jme z points away from you, y points up.

Just rotate your model…

Wait the blender importer does handle that?, at least i dont have such problems. Or does it happen only with animations? if so thats a bug that should probably be fixed.

It doesn’t matter how you orientate the model, if you animate it to move forward in blender, it will move sideways in the SDK.

And yes the problem is just in the animation, the model itself is fine.

if you use ogre2blender then in export panel there is an option swap axis
with 3 option

have you tried them yet ?
my default was xz-y (dont know if it works)

Ogre didn’t seem to have the same axis problem at first, it just had parts of the mesh in the wrong places when an animation was played.

I remade the model and tried again with the model rotated differently and ran into the exact same problem that the SDK importer had, the model traveled in the wrong direction when an animation was played.
The different axis options just orientate the model differently, the animation still played sideways.