Animations are distorted

I am attempting to load a .mhx file from makehuman to blender, animate it, then export it as ogrexml, then import it to jme3. Everything works fine except my animations come out distorted. I am assuming this is due to something I have ,or have not done in blender before exporting.

This animation is supposed to be a basic lift of the arm. The picture is taken at the point in the animation where the arm is supposed to be straight up.

Here is my blender file -

This is a picture of the animation while running in game -

I have watched a number of the tutorials and have done what I believe are the basics but maybe I’m just missing something simple.

Apply all rotations and scales before exporting. And check the info in HelloAssets.

1 Like

Haha, my favorite response to this sort of problem.

I have not modified the scale or rotation after importing and I do not see anything in HelloAssets or HelloAnimations that looks different from what I’ve done other than the blender version I am using, 2.62. I have read through the two popular pdf guides on texturing and animating in blender and exporting and I got a successful simple cube animation to import no problem.

This one, and every other complicated model I use seem to screw up though. If anyone who has dealt with this issue before knows whats going on and can help, or someone has the time to look at my blender file and let me know if they see an error, it would be much appreciated. I have a gut feeling that it has to do with the armature itself since it is imported from makehuman, but I can’t find what is wrong.

@wabashton said:
Haha, my favorite response to this sort of problem.

Haha, that's because it is the answer to your problem, it doesn't matter when you modify the scale or rotation... you need to apply it when you export animations or you get the problem you are describing

(select the mesh hit Ctrl-A)

EDIT I've used blender 2.62 as well and i got it to work no problem... after having the same problem you described, and after having apply the transforms, it fixed it
1 Like

Ok, then apparently I am doing it wrong. I believe I have tried what you are talking about due to the fact that it is posted as the answer everywhere but there is always the option that I am missing something.

What I do just before exporting:

  1. Select both the mesh and skeleton in object mode.
  2. Hit Ctrl-A and select location
  3. Check the boxes for rotation and scale that appear in the bottom left of the window
  4. Export ogre (.mesh and .scene)

    I have also tried this selecting only the mesh and not the skeleton and I have tried doing it before animating as well as after animating. Is there some method of actually applying this or does checking the boxes do it.

Hmmm… that should be enough i would think…

i did it after animating, so you should be alright there…

do you use the .mesh.xml file in JME? i had some slight distortions when using the .j3o object instead of the mesh.xml

I have been using the .j3o but I just tried the .mesh.xml as well. I can’t tell a difference. Also note that this is not a minor distortion. Instead of raising his arm 60 or so degrees he lowers it and the arm stretches to 3 or 4 times its length.

Just bumping this up, hoping for a solution before I give up the 3D characters for a bit and move on to the other parts of the game.

OK, so I didn’t actually give up and finally I found the solution. To anyone with animation issues use the code from the bottom of Hello Animation because it allows you to view the skeleton behind the animation. Mine was upside down and turned around for god knows what reason except the fact that when I applied the transforms using ctrl-a i was doing it after selecting both the mesh and skeleton with the a key. Ends up you have to apply it individually to each object because that is just how blender does stuff.

Thanks to norman and kbender, ends up it was the simple fix I though I had applied a hundred times, I had just been applying it incorrectly.

1 Like