Another animation problem :(

Hello,



I’ve been following a tutorial on Blender Cookie on how to make a dragon with animation, and when I try to export any animation of the dragon with Ogre into jMonkey, the animation loaded into jMonkey is twisted and it doesn’t work like it does in Blender.



I followed the HelloAnimation tutorial and everything works fine with other blender animations. I believe there’s something wrong with the rig that I made for the dragon. I tried to apply location and rotation and even scale, on the model and the rig, also added the Inverse Kinematics bone constraint on the bones before I animated them. Nothing seems to work.



Here is the blender file: This domain name is for sale. 100,000 USD



Please help, I’ve been trying to make this work for 2 days.



Thanks :slight_smile:



P.S. I made the animation in Blender 2.59 and I used the latest blender exporter (Ogre3D) addon.

If the mesh is distorted when you load it into JME and try to animate it… chances are you scaled either the mesh or the armatures outside of edit mode.



In Blender, open the view properties window and look at how the scale is set when you select both of these (one at a time of course). If they read anything other than:



X: 0.0

Y: 0.0

Z: 0.0



Write down the scale you applied. Set them all to 0. Go into edit mode and apply the scale there. Since your exporting the mesh outside of a scene, world scale/transforms/etc do some messed up stuff to your models. Use local only as a rule of thumb.

Oh… guess I should mention, this may effect your animations/vertex groups/etc… so be prepared for a rework on your pose library :frowning:

Hey, thanks for the fast reply :slight_smile:



For both my mesh and armature scale is set to :

X: 1.0

Y: 1.0

Z: 1.0



When I try to set them to 0, they disappear and even if I try scaling back in edit mode, nothing happens, I can only see a small orange dot.



Am I missing something?

Here are the exported files from blender, if anyone has the patience to check it out:



http://uploading.com/files/f414mfa2/Dragon.zip/



The animation is suppose to be a head turn, rotation on the Z-axis, and it comes out all wrong in jMonkey :-<

Sorry… I meant 1 :frowning: Flu has me really fuzzy.



Can you post a screen show of what you mean by the animation being twisted? << forget this.

@freakdudette said:
Here are the exported files from blender, if anyone has the patience to check it out:

http://uploading.com/files/f414mfa2/Dragon.zip/

The animation is suppose to be a head turn, rotation on the Z-axis, and it comes out all wrong in jMonkey :-<


Are you setting the up-axis to Y on the scripts > Orge Export window?

OK, these are my settings for Ogre Export:



http://img406.imageshack.us/img406/9877/ogreexport.jpg



This is a frame of the animation in blender:



http://img402.imageshack.us/img402/3827/dragonblender.jpg



And this is how the animation is twisted in jMonkey:



http://img192.imageshack.us/img192/9092/dragonjme.jpg



He’s suppose to turn his head left and right, and he’s almost nodding in jMonkey but in a very creepy way )

Make sure the transforms are applied on both the armature and the model

http://wiki.blender.org/index.php/Doc:2.6/Manual/3D_interaction/Transform_Control/Transform_Properties#Applying_Transformations

Hey nehon, I already applied Location and Rotation and Scaling to both model and armature, it isn’t that :frowning:

Hmmm…



During the export process you should be able to switch the up axis to Y. In blender it defaults to Z. I’m using Blender 2.49b (I think it is) and the export options has a switch up axis to Y option. This would definitely be the problem your seeing, I am just not familiar with how to change this option in the version of blender you are using.



Ah… I see it in the options panel where it says Swap Axis… I just don’t know what the right option is.

1 Like

Thank you so much!!! That was it, swap axis -xzy :smiley:

Yay I’m so happy! At last I can make this dragon fly :smiley:

Hi,



I downloaded your blend file and exported it

but as, with my wn project(blend) i get the same result

the bone is animated in the scene as i run my simpleapplication but the mesh does not move at all



can you please tell me what i do wrong ?



i use the official release(precompiled) of jME Platform sdk



is there a bug reported for the alpha ?



i compared the ninja example files with mine, it seems the xml of the mesh is not really defined the same way

but the links between the mesh/skin, bones and animation seeems ok

i don’t get it



does anyone faced the same issue ?

omg -xzy thx

I solved the problem by changing the -xzy, but in another mesh I continued with the issue, to solve it I removed the parent from bones and meshes, it seems that the model was moved after parenting and when I removed the bones, all meshes were “free” and not in the right place (they were just like in jme) so… I removed the parent, adjust to the origin the mesh and it worked.