App crash with PQTorus

Odd issue, since it popped up while you were moving through the shape and I assume you don’t do any updating to it in update(). You are using larger numbers (20, 50) than I usually do, but other than that… shrug

If you can figure out a way to repeat the issue I’ll see if I can troubleshoot. Given where the error was thrown, I can only think it might be an indice pointing to a non-existant vertice or something, but I’d imagine that would be an issue that would show up immediately, not upon moving through the shape.

I’ve tried everything I could to recreate this with no luck. I’ve used your exact parameters, I’ve moved through the torus multiple times, I’ve tried other torus settings, etc. I can’t get the crash that you received. Are there any other suspect settings in your application that might have contributed to this that we can test?

fwiw, I got the same results as Mojo in my tests. I also tested this on my oldest card (gf2) with no problems. What was your card again?

My card is an NVIDIA RIVA TNT2 Model 64/Model 64 Pro.

As far as I know, there were no other extenuating circumstances. However, my application has quite a bit going on: terrain, 4 widget viewports, shapes, etc.

If I have time later this week, I will try to get it to happen again. I did try it one more time immediately after making the error post, right before I removed the code, and it didn’t happen then either.

If it was something other than a fluke, it’ll show up again, so it’s probably not worth spending a lot of time on right now. I just wanted to record it for posterity or in case it was something really obvious.

Seems like an issue relative to your local setup unfortunately. I’ve never come across this issue. Is there any other factor you can think of? Time app spent running, render states applied, etc? What does your scene tree look like?

Maybe, but good luck getting a response. :slight_smile:

princec made this comment on JGO:

You can only use glDrawRangeElements if you've first checked for OpenGL12. Otherwise you must check for EXT_draw_range_elements and use glDrawRangeElementsEXT.

And it's broken on ATI 128 powered laptops


with your error originating at:

Current Java thread:
at org.lwjgl.opengl.GL11.nglDrawElements(Native Method)
at org.lwjgl.opengl.GL11.glDrawElements(Unknown Source)

Perhaps this is somehow related, although I don't see how the bug would only show itself periodically. If there is a problem with that call, it should never have worked. And if we are required to check for 1.2 before using glDrawElements, which is the method part of the GL11 class?

Anyways, not sure if this is related to our issue or not, something to think about though.