ATI Issue

Hello All,

I’ve been using jMonkey for a few weeks now and am enjoying it. I am having an issue however. It seems on my main machine that 2 things occur.

  1. the first child added to rootnode does nto render though the rigidbodycontrol is there.
  2. the flyspeed doesn’t adjust the same as on other machines.

    You can imagine how difficult this was when I was going through the tutorials. I ended up using my wifes laptop.

    I have tried the following.

    uninstalling and reinstalling jMonkey

    uninstalling and reinstalling java

    restarting the machine.

    all of the above.

    updating and downdating drivers for the ati card.

    My machine:

    win7 pro sp1 64bit

    intel quad core Q9550

    8gb ddr

    HD4870x2 (not crossfire, the actual x2 model)

    from jmonkey about

    Product Version: jMonkeyEngine SDK 3.0RC2

    Java: 1.6.0_34; Java HotSpot™ Server VM 20.9-b04

    System: Windows 7 version 6.1 running on x86; Cp1252; en_US (jmonkeyplatform)

hm do you have a light in the scene?

no, but the other objects render. This also happens when I run Hello SimpleApplication. THe blue box never shows. if I add another box , that one shows.


floor = new Box(50, 0.5f, 50);

floorgm = new Geometry(“upperLeft”, floor);


floorgm.setLocalTranslation(0,-12.5f , 0);

floorrbc = new RigidBodyControl(new BoxCollisionShape(new Vector3f(50, 0.5f,50)), 0.0f);







this is the first object. the other objects are identical except for names. I’d be happy to post the code. Yes, this is a final project but I can work on my wifes laptop and be fine. I am trying to troubleshoot the issue on my main computer as it is far more powerful and comfortable to use.

Hm well, one thing you could try for a simple test. (i btw have ati also, so its not a ati issue)


→ test a different java based 3d game (that ues lwjgl)

→ Possible to rule out LWJGL as cause

Test2 downalod uniengine heaven benchmark, and compare opengl and direct3d mode

→ test if different optics, slightly performance difference is ok tho.

→ Possible to rule out OpenGL driver bugs


→ downlaod a ubuntu live cd (i suggest xubuntu since the better user interface)

→ install the ati driver on it

→ download and test the sdk there, if it does exactly the same.

→ Possible to rule out operating System as cause

Test whatever you are capable of with a similar comparing idea, to rule out as much as you can, untill you find a probably cause.

→ Also graficdriver updated?

→ And all os updates?

I can try some of that. I’d need to find a game to use.

Yes I am all up to date on drivers, os and jmonkey

Minecraft plays…

ran the unengine

in direct modde i got a 1902 score and in opengl i got a 32.

opengl performed horribly but ran.

I have the same issue with my ATI 5970 and latest drivers.

I had to revert to febuary 2011 drivers.

I think it’s an ATI against opengl related issue…

That’s very annoying.

I ran the uningine once with these drivers and I had very better perfs.

Minecraft runs though…maybe that’s a LWJGL issue…

feb 2011? wow.