Begginer: Built CVS but unable to run tests

As said in the title, I get javac errors when compiling the test files. jME itself builds just fine making me feel confident enough to post this on the forum. I am, as a matter of fact, a complete n00b and this is my first attempt at compiling a CVS. This is what ant spits back at me when attempting 'ant dist-test' in the jME CVS directory (same place as i ran 'ant dist-all' supposedly succesfully).

    [javac]                   ^
    [javac] C:Program FilesJavajmejme-cvssrcjmetestrendererloaderTestMd cannot find symbol
    [javac] symbol  : method setModelBound(com.jme.bounding.BoundingBox)
    [javac] location: class com.jme.scene.Spatial
    [javac]             r.setModelBound(new BoundingBox());
    [javac]              ^
    [javac] C:Program FilesJavajmejme-cvssrcjmetestrendererloaderTestMd cannot find symbol
    [javac] symbol  : method updateModelBound()
    [javac] location: class com.jme.scene.Spatial
    [javac]             r.updateModelBound();
    [javac]              ^
    [javac] C:Program FilesJavajmejme-cvssrcjmetestrendererloaderTestMi cannot find symbol
    [javac] symbol  : method setOverridingLocation(
    [javac] location: class com.jme.util.TextureKey
    [javac]         TextureKey.setOverridingLocation(TEXdir);
    [javac]                   ^
    [javac] C:Program FilesJavajmejme-cvssrcjmetestrendererstateTestFra cannot find symbol
    [javac] symbol  : method setTextureBuffer(int,java.nio.FloatBuffer,int)
    [javac] location: class com.jme.scene.shape.Quad
    [javac]         q.setTextureBuffer(0, tex1, 1);
    [javac]          ^
    [javac] C:Program FilesJavajmejme-cvssrcjmetestrendererstateTestFra cannot find symbol
    [javac] symbol  : method setTextureBuffer(int,java.nio.FloatBuffer,int)
    [javac] location: class com.jme.scene.shape.Quad
    [javac]         q.setTextureBuffer(0, tex2, 2);
    [javac]          ^
    [javac] C:Program FilesJavajmejme-cvssrcjmetestrendererstateTestRen getTimer(java.lang.String) in com.jme.util.Timer cannot b
e applied to ()
    [javac]         timer = Timer.getTimer();
    [javac]                      ^
    [javac] C:Program FilesJavajmejme-cvssrcjmetestterrainTestTerrain.ja
va:126: cannot find symbol
    [javac] symbol  : method setStoreTexture(boolean)
    [javac] location: class com.jme.image.Texture
    [javac]     t1.setStoreTexture(true);
    [javac]       ^
    [javac] C:Program
:125: cannot find symbol
    [javac] symbol  : method save(com.jme.scene.Node,
    [javac] location: class com.jme.util.export.binary.BinaryExporter
    [javac]         BinaryExporter.getInstance().save(t, new File("C:/testBox.fa
    [javac]                                   ^
    [javac] C:Program
9: getTimer(java.lang.String) in com.jme.util.Timer cannot be applied to ()
    [javac]         timer = Timer.getTimer();
    [javac]                      ^
    [javac] 94 errors

C:Program FilesJavajmejme-cvsbuild.xml:124: Compile failed; see the compile
r error output for details.

Total time: 7 seconds
C:Program FilesJavajmejme-cvs>

I only grabbed the last bit since it's all pretty repetitive. Please help! I'm itching to get to work with this! :)

Is anyone else seeing this locally?  :?

works for me…

it seems like your testcode is up to date but not your jme core… (getTimer(java.lang.String) dissapeared one or two checkings ago for example)

That's odd. I just installed Ant and WinCVS today particularly to get the jME CVS and did so by simply requesting 'jme' from the cvs repository. I'd expect that to hand me the most recent core, lwjgl and test files.  :?

Uhm, i don't have to move the built core files do i? That would seem logical to me but it's not mentioned anywhere. I'm sure I'm doing something wrong.  :oops:


Ha! It worked. I had tried using the binaries earlier and the jars were still in my libraries folder. Apparantly those were being used instead of the new build which, in my humble opinion, is a strange preference. Anyway, I'm relieved :slight_smile: Now I can finally test it and get to work. Thanks for alerting me to the fact that something was outdated considering that's what reminded me I still had the older jar's in place.

Edit 2:

I spoke too soon. I thought running it would be a snap (and it probably is) but even that simple step is leaving me in the dark. Just to be clear: ant built the CVS core and test files both succesfully.

The files are located in: 'C:Program FilesJavajmejme-cvs'

I run the following line to try TestDynamicSmoker (copied directly from the GSG):

C:Program FilesJavajmejme-cvs>java -Djava.library.path=./lib -cp ./lib/lwjgl


est.jar;./target/jmetest-data.jar jmetest.effects.TestDynamicSmoker

Exception in thread "main" java.lang.NoClassDefFoundError: com/jmex/effects/part


Others generate errors as follows:

C:Program FilesJavajmejme-cvs>java -Djava.library.path=./lib -cp ./lib/lwjgl



ar;./target/jmetest.jar;./target/jmetest-data.jar jmetest.renderer.TestScenegrap


Jun 12, 2006 11:42:01 PM start

INFO: Application started.

Jun 12, 2006 11:42:01 PM com.jme.system.PropertiesIO <init>

INFO: PropertiesIO created

Jun 12, 2006 11:42:01 PM com.jme.system.PropertiesIO load

WARNING: Could not load properties. Creating a new one.

java.lang.NoClassDefFoundError: com/jmex/awt/lwjgl/LWJGLCanvas

        at com.jme.system.lwjgl.LWJGLSystemProvider.<clinit>(Unknown Source)

        at com.jme.system.DisplaySystem.getSystemProviderMap(Unknown Source)

        at com.jme.system.DisplaySystem.getSystemProviderIdentifiers(Unknown Sou


        at com.jme.system.lwjgl.LWJGLPropertiesDialog.setUpRendererChooser(Unkno

wn Source)

        at com.jme.system.lwjgl.LWJGLPropertiesDialog.createUI(Unknown Source)

        at com.jme.system.lwjgl.LWJGLPropertiesDialog.<init>(Unknown Source)

        at Source)

        at Source)

        at jmetest.renderer.TestScenegraph.main(Unknown Source)

Jun 12, 2006 11:42:01 PM cleanup

INFO: Cleaning up resources.

Jun 12, 2006 11:42:01 PM start

INFO: Application ending.

Essentially java doesn't seem to be using the libraries specified in the command line. I'm feeling ridiculously dumb here.  :expressionless:

Back again… After looking around on the forum and having heard about a number of good IDE's, I decided Eclipse might be a good move from my simple little university-issued JCreator. I still need to learn the ropes as it's pretty robust but it got jME running in a jiffy! Test files are even easier to load (as I cringe at every command line interface :P) I'm surprised it's not used more often considering it replaces Ant, WinCVS and the command console and doesn't even require any fiddling or configuring along the way. I'm still curious as to what my problem was (and technically still is) with the previous set-up if anyone's willing to help out.  :slight_smile:

You're wondering why what isn't used more?  Surely you don't mean Eclipse…the #1 IDE in the world do you?  :-o


Maybe he means at his university.

(flame)Actually Eclipse might be #1 'free' ide, but I am in love with an "idea"- even she is a commercial bitch. :stuck_out_tongue: (/flame)

Hehe, got people talking about Eclipse now instead. I actually meant that I'm surprised it isn't used more in general as I'd never heard of it. That's mainly due to the fact that I origianally learned Java at the uni and didn't move into more in depth stuff until now. Apparantly all a university course really needs is a quick and simple Java editor that can compile and run. Eclipse would be major overkill as everything made there is done with the goal of learning object oriented programming and not using CVS or anything fancy.

Anyway, to get back on topic: Does anyone know what I'm doing wrong in the last "code" bit I posted? I've got jME working in Eclipse without compiling with Ant but I think it'd be very handy for me to know what to do on the Ant/command console path.

i thought you were still compiling with ant but through eclipse? you really need to get that ant stuff working…

With your advice I decided to give it another shot and ended up getting it to work in a kind of odd way. I ran the build file (and included the docs in the jars by editing the build.xml as explained in 'setting up eclipse to build jme') out of Eclipse with ant, first executing dist-all and then running it a second time selecting only dist-test, and lo-and-behold it built succesfully. I have no idea why it didn't build the test files through the command console (although I did have Eclipse take care of redownloading the CVS so maybe the first download was corrupt or WinCVS mucked it up.) Anyway, I then copied the created jars back to the folder where I originally tried to build jME, overwriting the jars there. I did this only for the sake of testing what the problem was as I know it works from my Eclipse workspace. Running the same commands from the command console as before I now get results. Everything runs fine :slight_smile: (I'm still clueless as to what the problem was before though…)

Thanks for the help!

jcreator? you were blessed then! they wanted us to use visual cafe at the university. i happily resorted to notepad. :slight_smile: