Beta version of Fearkill

Fearkill is now finally in an almost finished version. It is a horror shooter and you have to survive in different maps with different weapons etc.


This is the trailer:

You can download it and find additional information at: Fearkill Windows, Mac, Linux game - Indie DB

The game is still in a beta version because it is really difficult and I plan to add some features to make the game easier, which will of course be completely optional. However you can still play through it if you are good enough :wink: Maybe my tester was just really bad but I think the shop is good idea anyways (you are just gonna pay with ingame money, I’m not EA). So this is essentially the full game without some tutorials / practice levels and without the shop.
Any feedback is appreciated :smile:


the url must be one complete line, not embed in a sentence

Nice stuff :wink: good work

1 Like

I am trying to run the game on Ubuntu 14.04 and I am getting the same error no matter which file(.sh or .jar) I use to run the game,

Error In Application:
RuntimeException Unable to find fullscreen display mode matching settings.

My display resolution is 1920 * 1080.

You game looks good! :slight_smile: Put some trees please :smiley:

I guess Fullscreen + Framelock + Vsync might be causing trouble… The settings are actually saved with this line:

private final static Preferences prefs = Preferences.userRoot().node("/net/softwarepage/fearkill");

In windows this is the registry I’m not sure where you find this on Ubuntu. There you can create a new key with these values (“resolution”, “1280x720”), to let it run in 1280 x 720.

What refresh rate does your monitor have?

I don’t know if there is any windows equivalent in ubuntu. I don’t think so, and even if there is it’s our of my knowledge.

Is there any global variable I can set?

I tried using xrandx command to get refresh rate and I get 59.9+ and from nvidia control panel I get 59.93

I just rebuilt the project with different settings. You can download the new linux jar and .sh here. Copy them into the same directory as you lib folder is and run it. jar link; sh link It should start in windowed mode now, so it should work…

Could not find the main class: net.softwarepage.fearkill.Fearkill the program will Exit. I think the game is missing a file ( I am using windows OS)

It’s working now! :slight_smile: One more feedback, could you please increase the view distance.

@iamcreasy yeah I planned to do that with the final release
@eth This is really strange. From where did you donwload it? :’(


Did you extract the zip directory and started the exe from there?
You could also try downloading this jar, putting it into the same directory as the (extracted) lib directory and running it. I’m not quite sure what else could be the problem…

I did try that and it didn’t work :confused: I tried to dowload the jar and I put it on lib folder but it didn’t work
:frowning: also I tried to run it as admin and it didn’t work :frowning: @mathiasj

Since the issue only exists on your system I guess it depends on your java version or something like that…
I read somewhere in the internet that you could try running the jar with java.exe or javaw.exe (one of them is the default be sure to also try the other one).

Can you run it from the command line with
java -cp Fearkill.jar net.softwarepage.fearkill.Fearkill ?

@mathiasj I already have the lastest version of java :frowning: I already tried to run it in cmd but I had that:

java -cp Fearkill.jar net.softwarepage.fearkill.Fearkill
Exception in thread “main” java.lang.NoClassDefFoundError: net/softwarepage/fear
Caused by: java.lang.ClassNotFoundException: net.softwarepage.fearkill.Fearkill
at$ Source)
at Method)
at Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
Could not find the main class: net.softwarepage.fearkill.Fearkill. Program will

I already tried an other game here on forums and it worked very well :frowning:

I really have no clue what could cause the problem… It worked on every machine I tried and my friend didn’t have that issue either… The main class definetely exists in the jar and I can run it without any problems. Very strange…

Run these commands also:
java -version
jar -tvf Fearkill.jar

(the last one presumes you have the JDK bin directory in your path.)

java -version
java version “1.6.0_45”
Java™ SE Runtime Environment (build 1.6.0_45-b06)
Java HotSpot™ 64-Bit Server VM (build 20.45-b01, mixed mode)

java -tvf Fearkill.jar
Unrecognized option: -tvf
Could not create the Java virtual machine.

not “java -tvf” but “jar -tvf”, you can also share the size of the jar.

Yeah… o/’ “…which of these things… is not like the other…” o/’ :smile: