Blender 2.61 Animation Issues

Hello, I’ve been searching everywhere for a fix to my problem, but so far I’ve found nothing that solves it.

I created a Blender animation, a little robot made of boxes. I’ve rigged, skinned and animated (walk) the robot on Blender just fine, and on Blender the animation of the robot walking works as intended.

However, when I load the robot on JME3, following the HelloAnimation tutorial, when I play the walk action the robot legs animation is completely wrong. I’ve tried the visual transform fix, but it makes no difference.

So I decided to test the animation with the model from the tutorial, Oto, and it works perfectly fine. That should mean that the problem is on my Blender animated model, but I sincerely can’t think of anything that I did wrong. Could it be a problem with the Ogre3D exporter?

Here is my test case: download.

I’m using Blender 2.61 and jMonkeyEngine SDK 3.0beta

Apply the rotations and translations of your objects before exporting.

In case that doesn’t work, maybe you can find the solution here. It looks you have to use a root bone centered in model’s origin. It’s strange, but it might be a bug of the newest ogre-meshes-exporter.

normen’s solution didn’t work.

glauco, by root bone you mean a bone which is the parent of all the other bones? I didn’t have one, so I just added one but I didn’t work either :frowning:

Yes it is. Did you read the entire topic in link above? Btw what kinda animation are u using? Only B-Bones doesn’t work. Try doing normen’s solution and the other solution in the same time.

Thanks for the help.

I’ve created another model using the root bone, but the same problem happens. I did read that thread glauco linked but unless I did something wrong on the model, it just doesn’t work.

I did debug the armature on JMP and it shows that the problem is in the armature:

How it is on JMP:

How it is on Blender:

Before exporting the model I did apply the location and rotation transforms. One thing I noted though is that each time I apply “Visual Transform” the whole object flips 90 degrees on the x-axis.

Yeah I’m using only B-Bones to animate the model, what else do I need to make it work on JMP?

If your model of armatures are being scaled outside of edit mode, it would cause issues.

Set global scale & position to 0 : 0 : 0. and scale/position them in edit mode, prior to animating.

Hi, I am having problems with animations as well.

I have tried setting location/rotation/scale to 0 before animating in blender. The animation still ends up distorted beyond use when I import it in JME.

A step by step guide on how to make this work world be really nice :slight_smile:

do not apply visual transforms, apply the location and rotation transforms for both model and armature.

@tkjerner said:
Hi, I am having problems with animations as well.
I have tried setting location/rotation/scale to 0 before animating in blender. The animation still ends up distorted beyond use when I import it in JME.
A step by step guide on how to make this work world be really nice :)

Have you got it working?

I've had no luck so far, I've been trying for like 4 days now... so please, if you get it working could you provide a tutorial?

I'll keep trying, if I get it working I will make a video showing how its done.


I think I got it working, however I’m unable to play two different animations on JMP.

On Blender I’ve set two actions (walk and jump), when I export to Ogre both animations show up on the .xml generated. On JMP though it makes no difference if I setAnim(“walk”) or setAnim(“jump”), both play the jump animation.

It looks like I’m exporting something wrong, anybody has any clue what could it be?

I had that problem at one point.

I found that only the active animation action was exported, making all the animations similar. If you export once for every action and then paste all the actions into the first script then that part should work.

Oh and If you have solved the animation distortion problem then please make a guide :smiley:

I personally hate the 2.5/2.6 exporter… for one thing it’s more work :frowning: also unless it’s a 2.5 thing object scaling on armatures should have no adverse affects on animations in fact I have found that while applying transforms was a good idea for the mesh objects doing that to the armature actually screws my animations …I have scaled armatures and have them export and come into jme3 just fine…but I took the decision the maintain character animations in 2.4x,… I find my self modelling more in 2.6 but mostly buildings and props…mostly due to useful addons that save time and effort…

Made a video showing how I’ve done it. Unfortunately I had to cut a lot of footage because I can’t upload more than 10 minutes.

And no sound too :x
1 Like

Thx for doing the video. I followed the it but the animation is still messed up.

What is the single action in Blender that you need to do to make it look right, and at what time do you need to do this?

To me it looks like it is something before the start of the video. Perhaps in the rigging?

Nothing special, just before animating you need to apply transforms (rotation and location) with CTRL-A.

I did that but my animation is stilled messed up :frowning:

do you use inverse kinematics?

Ok, i fixed your model…

that one works:

just rightclick on a file and convert to j3o. Then take animation control and switch animation on.

you had mess of many things (mirror modifier is not applied, bones hierarchy was in mess, vertex groups were in mess, Bone Envelopes were switched ON).