Blender model gets 2 animcontrols, can't delete one of them

My model works fine in Blender with 6 bone animations.

It has worked earlier with JME, but now it doesn’t work anymore. I don’t know why, the .blend file has not changed.
I may have switched to nightly and back again, since I was recommended in another thread to use nightly because it imports better.

When it did work, I was not using nightly.

This happens when I view the model in the scene editor:

It gets 2 animcontrols, one of them contains all 6 animations and they run as they should, the other contains 1 animation which runs, but not as it should. something is obv wrong here.

I tried deleting the animcontrol that has errors, but nothing happens apparently. Reloading the model file shows the error-animcontrol again just as if it was never deleted.
Why is there an option ‘delete’ if it doesn’t delete anything?

When running the game, only 1 animation runs. The one that runs is the ArmatureAction.000 and it runs correctly. The others just dont activate. It’s as if the error-animcontrol decides which can be accessed, but the actual animation is run from the “healthy” one, since the one animation that runs, does so correctly.

Here’s the blend file