Blender Object issue

I just updated my sdk, and now i’m seeing an interesting message in my console

Feb 13, 2012 8:49:08 PM class com.jme3.export.binary.BinaryImporter readObject(int id)

SEVERE: Exception

java.lang.ClassNotFoundException: com.jme3.scene.plugins.blender.objects.Properties



at Method)


at java.lang.ClassLoader.loadClass(

this ultimately comes from this line

model = (Spatial) myApp.getAssetManager().loadModel(“Models/wizardBlend/wizardPurple.j3o”);

where i load a j3o. object that was made by converting a .blend file to a j3o… It looks like i’m missing a blender plugin, but i looked through all the sdk plugins and i couldn’t find any that looked like the one i needed.

The program still runs, it would just be nice to fix this so it doesn’t spam the log/ it looks like it is useful for the save node operation…

@Kaelthas, what is this dependency?

i suppose this is Object Custom Properties in Blender.

@kbender88 , just remove them if you want to get rid of the Exception.

@mifth is right.

These are indeed object properties.

I just do not know why the classloader cannot find this class.

It is located in the same location as all other blender loading classes.

I’ll update the jmp when I get home and I’ll check if I have the same error.

@Kaelthas: Why do you do that? You can use UserData for that like the OgreXML importer.

Since the blender loader is not included in core, no classes from it should be placed inside J3O files

It is not included in the core. But if you try to load the blender model in jmp you have the proper plugin installed and the class should be available.

It is in the same package as ObjectHelper which is always loaded earlier by the ClassLoader than the Properties class.

I didn’t know about the UserData class.

I’ll check it out and maybe I will replace my class with this one if it will not break anything.

It will give us one class less. :slight_smile:

I removed the custom properties but I still get the same error?

I tried removing everything from the custom properties (for all tabs in all the scene objects). Still, the problem remains :frowning: