Bug when running Renanse's Particle Editor


I tried running

Renanse's Particle Editor today, but I get the following error:

java.lang.NoClassDefFoundError: com/jmex/editors/swing/particles/ParticleAppearancePanel

at java.lang.Class.getDeclaredMethods0(Native Method)

at java.lang.Class.privateGetDeclaredMethods(Unknown Source)

at java.lang.Class.getMethod0(Unknown Source)

at java.lang.Class.getMethod(Unknown Source)

at com.sun.javaws.Launcher.executeApplication(Unknown Source)

at com.sun.javaws.Launcher.executeMainClass(Unknown Source)

at com.sun.javaws.Launcher.doLaunchApp(Unknown Source)

at com.sun.javaws.Launcher.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

Any ideas?

I tried running the webstart from the site, haven't tried the CVS version yet.


looks like webstart is missing a jar.

jar has now been added to webstart and the editor runs.

still not running from my end. Could it be I need to clear some sort of cache somewhere?

The webstart cache is in Control Panel->Java->General Tab->View button at the bottom. It should list the apps, and you can clear them out there.(assuming you're in windows)