Cannot login to the forum using facebook

Hi guys!

My jme3 forum account is facebook based and I cannot login anymore. facebook login shows this error:


Sorry it’s in spanish but the translation would be more or less: “Function is not available. Facebook login is not available currently for this application”

Hopefully I had other browser keeping my session so I can write this here :stuck_out_tongue:

Thanks and happy new year monkeys :wink:


While it’s not solved, I’ve found a workaround… Probably not the best option for most people but if you’re lucky enough and, as me, you have any browser keeping the site session, you can link your account to google and/or github or even overwrite your password so you can login again from other browsers

You can also request a password reset from any browser:

  • Click “Forgot Password”
  • input the email that is associated with your facebook account. (Discourse uses email addresses internally as the “Real” identity, so it’s pulled yours from your facebook profile.)

I think this is happening because facebook changed their rules a few months back to be more compliant with GDPR and similar. Site admins need to provide a URL to documentation on the site’s Data Privacy Policy, as well as instructions for data-deletion requests. Once that is in place, facebook should, theoretically, re-enable the integration from their end.

@staff This can be as simple as linking to the standard T&C, as long as it covers these points.

1 Like

The forgot password didn’t work for me :confused: That’s why I started this thread

And yes, facebook from time to time changes the policy or the API and everything fails. I have some apps using FB APIs and it’s a mess to keep them up to date

Now that you’re logged in, check your “Primary Email” in your preferences. Is it the same as the email that you tried to use to reset your password?

It doesn’t work for anyone right now. I think @RiccardoBlb has to update something in the facebook dashboard, but first get access to the facebook application from probably the last person who managed the site, unless that was handed over to the team already.

Yes, my mail account is the good one but never received the reset password e-mail. And yes, I double checked my spam folder

Anyway, for me it’s ok now that I can login again :wink:

I rewired the facebook auth to a new facebook app, the old one was configured by whoever did the initial forum configuration, i guess it broke with some recent change. It should work now.


I confirm it’s working now. Thanks

1 Like