Can't import anything from blender

I tried Blender 2.63 with last export script from this thread

I tried 2.63 and 2.59 with script installed by JME tool.

I tried even 2.49 with old exporter.

And all i getting is:

All I need is mesh, normals and UVs. I don’t need materials, skinning or animation.

What else I can try? Is there any other way for importing models? How can I get more details about my error?

Blender 2.63 has changed the internal format of the file. You need to do a save as and then tick the “legacy mesh format” file…or if you use the latest nightly SDK then that has support for the latest blender format (and also has some nice upgrades to the quality of the normals imported as well).

@zarch said:
Blender 2.63 has changed the internal format of the file...

Yeah, I googled this phrase earlier. I tied to save legacy mesh format, then open the blend file, or export ogre xml. Nothing work for me. Do I really need to try nightly build to import model?

as your requirements are low (no animation), you can try exporting to .obj. Make sure to tick export normals, uvs and as triangles. There is also a direct blender importer.

Due to the many changes in blender lately the import process is a bit wonky right now (btw a good reason why you shouldn’t update software when doing a project, even if some new feature looks sexy). Though if you updated to the latest stable, using the ogrexml script that you can install using the SDK then (Tools->OgreXML) and Blender 2.62 should work. Getting the right settings for the model to make a proper game ready model with proper uv mapping etc. can be complicated if you don’t exactly know how to configure it in blender. Lots of ways to do something where you see a result in blender but it won’t translate to live gl rendering.

Well, I tried 2.62 with script installed via sdk tools. And obj format. Both shows same error.

That’s started to look like damnation!

…like I indicated this then most likely hints at the fact that you do something else wrong, check the documentation on asset organization and model/blender import.

I made it! I finally got something imported. It only works with right click → Convert to j3o binary , but same files doesn’t work with Import Model dialog. I thought, this both features have same functionality. Or does they?

Thank you all for replies.

If you don’t describe what you did thats hard to say. If for example the textures for a model are not in the same folder the model import tool will fail to import the model.