Can't load OpenAL library


I tried to run HelloIntersection from tutorials, but I'm getting an error :

ALSA lib pcm_dmix.c:874:(snd_pcm_dmix_open) unable to open slave
ALSA lib pcm_dmix.c:874:(snd_pcm_dmix_open) unable to open slave
AL lib: alsa.c:344: Could not open playback device 'default': P

  1. Please make sure your audio drivers are correctly installed and current.

  2. Similar problem has been brought up on the lwjgl forum. Please see this thread for details. There is also a link to another thread on the same issue in the first post of that thread.

  3. to quote duenez from the thread you linked to: Have you tried running the WebStart demos in the page? if those work, then we could be on track of better addressing this issue…

  4. <tries to summon duenez>

I have same problem, and i only can reset for fixit, but some minuts back, crash again

What is this? Im using Ubuntu Linux 8.10.

How can fix it?


Edit: 32bits! no 64bits!

Use openal-soft to fix this bug.

gouessej said:

Use openal-soft to fix this bug.

Hi, i get the same error using Ubuntu 8.10 64bit.
What I did:
- downloaded the openal-soft
- "makec"
- "make"
- "sudo make install"

Even after restarting my notebook, the same error still appear while working with the jME-StandardGame. However, extending from the SimpleGame-class works fine while running a StandardGame (game.start()) gives this error. My Audio driver are installed correctly, so there shouldn't be any trouble from that side.

Any idea what to do?

My code is following (quite simple and a built jME from repository used):

StandardGame game = new StandardGame("SitGoD");

        game.getSettings().setDepth( 16 );
        game.getSettings().setAlphaBits( 0 );
        game.getSettings().setSamples( 0 );


The error message is exactly the same as from the first post - after "game.start()" has been called.

Here's the code which works fine:


public class Test extends SimpleGame {

    protected void simpleInitGame() {
        display.setTitle("A Simple Test");
        Box box = new Box("my box", new Vector3f(0, 0, 0), 2, 2, 2);
        box.setModelBound(new BoundingSphere());

    public static void main (String [] args) {
        Test test = new Test();


You have to rebuild LWJGL so that it uses openal-soft or it will use the hardware buggy implementation.

Hm  :expressionless:

So Step by step:

1.) first i have to build & install openal-soft ? (that's what i've already done)

2.) download LWJGL source (done as well - from sourceforge)

3.) somehow change it so that it will use openal-soft ???

4.) somehow build it ??? (found no documentation how to build it on sourceforge or anywhere else)

5.) somehow install it ???  (just replace the LWJGL-files used in my jME-Project with the new ones?)

Sorry, i'm not that smart … or whatever misterious forces are needed … Is there any discription on a homepage? Seems to me that other people had the same problem but obviously solved it.

Maybe you can just modify the binaries of LWJGL instead of rebuilding the whole. I rather use JOAL and we had the same problem.